Axure 9 "Drag and Drop" slider issue

I had a slider control prototyped in Axure 8 that worked. I had referenced this tutorial. I imported it to Axure 9 beta and it seems to be broken. I’ve tried a few things.

  1. I checked variables and some of my local variable references were replaced with the ‘This’ reference. I fixed those, but was still having issues.
  2. It appears to be something with using left and right boundaries. I thought it was because I was calculating them using widget.left and widget.right, but when trying to use a fixed number it also didn’t work.
  3. While troubleshooting the variable thing, I also noticed some odd behavior with setText. I was setting text on a widget to help troubleshoot values and calculations. In some cases after using widget.x or widget.left it didn’t like me trying to put that as text on a widget. This might be unrelated, not sure. Does Axure 9 require a conversion of number to strings to place them as text?
  4. Removing the boundaries allowed me to finally drag the panel, but now there isn’t a boundary on it and it can slide the full width of the page and breaks the

Hi aequinn,

The slider from our training file is working fine in the 9 beta, so it looks like the issue may be specific to your custom slider file. Could you post that here so that I can see what’s going wrong? If you’d rather keep the file private, feel free to email that over to support@axure.com. Thanks!