Axure RP 10 Constantly Crashing When Working with Images



Ever since I have downloaded RP10 about a month ago, I have experienced probably 200-300 crashes while using the app. I’ve waited to make this topic because I wasn’t sure what the cause was. However I now believe it is something to do with images that have been imported into the pages. Any time I’m working with any images, I get constant crashes. Sometimes the app will be open for 5 minutes before it crashes, other times it will be open only a few seconds.

To compound this issue, anything I’ve created in RP10 cannot be reopened into RP9, leaving me with projects which I have to constantly remember to CTRL+S every 10 seconds to avoid losing work.

This is incredibly frustrating.

Axure Version

System Specifications:
Windows 11
Intel Core i9-10900K CPU @ 3.70GHz


Hi @jeremy.hesidenz, thanks for taking the time to write about this. I’m sorry to hear that you’ve run into so much trouble using RP 10! We haven’t seen other reports of constant crashing working with images in RP 10 so far, but we’d like to further investigate the issues you are running into.

Would you be able to send in some additional information to Including the following information will help our support team troubleshoot the issue:

  1. Have you noticed any other patterns or specific actions that lead up to the crashes? (e.g resizing images, adding filters, etc.) Any additional information or screenshots/videos you can provide may help us reproduce the issues on our end.
  2. Can you send any .rp files where you run into the issue, and/or any specific images that seem to cause errors?
  3. We’d like to review any error or crash logs from your machine. Error logs can be found here:


  1. If any of these are hard crashes where RP exits completely, there should be logs available at the Windows level. To locate these:

a. Open the Start menu and search for “Event Viewer”:

b. Open the Event Viewer application, and then navigate to “Event Viewer (Local) > Windows Logs > Application” in the left-hand sidebar.

c. Once there, select “Action > Find” and search for “AxureRP10.exe”:

d. Look for any “Error” level entries and any “.NET Runtime” errors that occurred immediately before or after the Axure RP error. [CTRL]-click these entries to group select them.

e. Go to “Action > Save Selected Events” to export the events to an EVTX file, and attach that to your email


I am experiencing tons of crashes as well a year later, but on a Mac and I’m not sure it is due to images necessarily. Seems to randomly crash typically when I have done a lot of work in a short period of time and haven’t saved yet! So painful! I have reduced my auto-backups to a few minutes which doesn’t seem to be enough time when I am really on a roll! Very frustrating here too!

Axure Version

System Information:


Hi @Darren-Kurre,

Sorry to hear that you are experiencing crashes on macOS.

To help us investigate this further, please email us at and provide us with the following information:

  1. Can you recall any events that happened before this issue started to occur? Has Axure RP previously worked on this computer? Do you recall if anything has changed on the system since then, an update of OS or installation of new software for instance?

  2. Do you have any file-scanning software installed on your computer such as antivirus/malware, security, or automated backup solutions like OneDrive? In past cases, this type of behavior has often been attributed to some such software intermittently blocking access to the working directories that Axure RP needs to perform correctly. If you do have any such software installed, please can you uninstall it and try launching Axure RP again?

  3. Have you tried uninstalling and then reinstalling Axure RP 10?

  4. Your Mac console logs, these can be found by opening the Console application on your Mac, clicking the “Diagnostic Reports” tab on the left side of the dialog, and then searching for any logs with “Axure RP” in the title. If you find any please attach those here so that we can check for any system-level errors and additional hints as to what is causing the crash.

  5. Does the issue occur with a specific file? Or does it occur with all files? If it is isolated to one file, can you share a copy of it for us to investigate further?

We would also like to get a copy of your Axure RP logs to review for further investigation. Please attach both the “error_log” and “post_log” files for the dates that you encountered this issue, from the directory below then we can take a look and advise on what errors are occurring and how to resolve them.

To locate your Axure RP MacOs logs, please navigate to the following path:

~/Library/Application Support/Axure/Axure-10-0/logs

To locate this folder open Finder and in the top menu “Go > Go to Folder” and paste in the path above.

We will look out for your email so that we can help resolve the issue as soon as possible.