Axure RP9 Lagging Issues in Mojave

bug-report

#1

Hey guys,

I updated my MacBook Pro (16GB RAM with plenty disc space) to Mojave last week and immediately noticed that Axure was lagging badly trying to scroll and move objects around on the screen, often overshooting intended stopping points and a 3 second delay in actually moving anything. Trying to get to the menus is like watching a slow motion video. This caused some project stakeholders to complain during a presentation which was extremely laggy.

I have updated to the latest RP9 update which made no difference.

I am running 10.14 Mac OS Mojave after upgrading from High Sierra. Axure RP9 worked perfectly well in High Sierra.

I reinstalled a fresh copy of RP9 on Mojave and that did not work.

I do not experience these lagging issues in any of my other apps.

The only thing I can think of which I am really trying to avoid is rolling back to High Sierra but this will cause compatibility issues with some of my newer app subscriptions like Sketch, Zeplin etc (I wonโ€™t be able to use the latest Sketch in High Sierra) - so are Axure trying to force me to decide between Sketch or Axure?


#2

Hi!

For anyone following this here on the forums, we received an email from brandonbotha earlier this week and were able to determine that this issue was due to some monitor scale settings. Setting the monitor scale to its default resolved the lagginess and allowed Axure RP 9 to function as expected on Mojave. :slight_smile:


#3

Yes, this issue is now resolved. My Dell 4K monitor was scaling to 1680px which seemed to have caused Axure to lag a lot during scrolling and moving objects. After switching scaling โ€˜offโ€™ Axure is performing well again.