Browser doesnt render corrent layout when converting to Masters

Hi

  1. I created a new RP9 Beta project.
  2. I setup adaptive views (320, 375, 768, 1024 and 1200
  3. starting from 320 I adjusted my design all the way up to 1200 view, from smaller to larger adding and hiding certain elements related to that view.
  4. from 320 view I converted to Dynamic Panel
  5. from 320 view I added an extra dynamic state and edited all the way up to 1200
  6. from 320 view I converted to Master
  7. All views inside Axure displayed the layout correctly
  8. When I viewed in browser, it seems the views 1024 and 1200 were missing some design elements and showed elements from smaller views.

Is this a known bug?
If its a bug and awaiting fixing, would I be able to carry on my work flow and for the time being not use masters (as it seems when I convert my design to a master thats when the issue appears.At a later date once you fixed this bug, can I convert to master or do I need to rebuild my project from scratch?

Regards
Chris

Hi tjcwebdesigner!

Thanks so much for the description of this issue. I followed the steps you shared and was able to reproduce a similar issue where some elements were missing and some elements from smaller views were visible.

I did find that where some widgets were missing, they were placed underneath the dynamic panel in that view, so that they were loading underneath other widgets on the page. I found that adjusting the order of the widgets in this case made it so that all widgets that were placed into the later views were visible. Please let me know if it looks like any of your view’s widgets are placed beneath other aspects of your dynamic panels in your widget order in the Outline pane, and if moving these widgets to the top of the order helped them to be visible for these views.

For the other issue where smaller views’ widgets were visible in your last two adaptive views, it sounds like you are encountering a bug that we have on file where master widgets not explicitly hidden or unplaced in a subview will be visible on pages with adaptive views.

I’ve previously had some success working around this issue un-placing masters, but only if I started by having the master widgets placed on all views, and then unplaced the master widgets in order of most-inherited to least-inherited adaptive view.

To do this, you would need to make all widgets visible on your adaptive views before you convert your dynamic panel to a master. Once the dynamic panel was converted to a master, you would want to unplace widgets from the most-inherited view, and then work backwards through each non-base view to unplace the widgets while the “Affect All Views” setting is unchecked. For your project, this order would be 1200, 1024, 768, 375, and then 320.

Please let me know if this method allows the widgets to unplace correctly. Additionally, I wanted to let you know that I will be adding a note to our bug report regarding your experience.