BUG Axure crashing when adding/removing targets in interaction window

technical-troubleshooting
bug-report

#1

I can’t get this bug to repro every time, but the general flow of when it happens is:

  • Create a new interaction
  • Add a show/hide, or set panel state (possibly any other interaction that allows multiple targets)
  • Add/remove a second target to the same action

Sometimes this works fine, but fairly regularly it’ll cause a hard crash. It doesn’t even let me submit the bug report as another error displays on top. Here is the screenshot ![image|562x500]
(upload://ghT9pdaooCkqQ9eJ8cBBflFYu1o.png)

error_log_2019-03-13.txt (199.7 KB)
The log is also attached.


#2

Hi!

Hmm it sounds like this crash is occurring on a regular basis when adding or removing a target from an interaction. To confirm, this is happening on Windows, correct? Do you happen to be using a standard desktop or laptop, or are you using something like a tablet PC or other special hardware? We’re currently working on tracking this particular bug down but have only been able to reproduce it on a Surface Pro so far; if you happen to be using the same type of device (or different) then that would be helpful for us to know.

Additionally, please let us know what version and build of Windows you are currently using. To find this, open the start menu on your machine and type “winver” into the search bar.

If you’re also able to attach your .rp file where you’re seeing this issue, along with steps on how to reproduce the issue in that file, then that would help as well. Thank you!


#3

This is on Windows yeah. It’s a Dell XPS 15 (brand new in January), so high end specs.
My Windows build is: 17134.590.
I can’t attach my file as there’s a lot of sensitive info in it. This is happening on all of my projects though.

Cheers.


#4

Excellent, thanks for sending that info! From the looks of it, the Dell XPS 15 from January has a 4k monitor. To confirm, is yours also a touchscreen?

If you’re able to reproduce the issue in all files, then would it be possible for you to create a new file with a simple sample interaction that triggers the same issue? If so then we can take a look at that instead of the current file. If the issue only happens in existing files, then please feel free to send one of those over to support@axure.com with a link to this thread so that we can take a look and assist you privately. If you happen to be able to include a video of the reproduction steps from your machine for that same file then that would help to follow along and reproduce the issue on our end.

In the meantime, from our testing it looks like this particular issue does not seem to occur if you edit the interactions in the new interactions editor instead of the interactions pane. To access the interactions editor, you’ll want to ensure that you’ve updated to the latest beta build (3635 as of this writing) and then click the interactions editor icon:


The above icon will open up a dialog similar to the case editor from Axure RP 8. We haven’t been able to reproduce the crashes in that dialog, so hopefully that will help to allow you to avoid the issue for the time being.

In the meantime, we’ll continue investigating the bug on our end. We’ll update this thread if there are updates, but otherwise please keep an eye on the 9 beta release notes thread for updates about released bug fixes. Thanks!

Thank you!


closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.