[BUG?] Repeater widget - widgets above are not part of repeater

System
Windows 10 Pro 64 bit
Axure 9.0.0.3628

Steps

  1. Create new file
  2. place repeater widget on design area
  3. double click repeater to edit
  4. place additional rectangle widget below existing (default) rectangle
  5. move new rectangle (just added) above existing (default) rectangle
  6. leave edit mode

Expected result
each repeater row shows 2 rectangles as shown in edit mode

Actual result
added rectangle is shown multiple times above all other repeater rows

Hi Ben!

I wanted to let you know that it would be expected that the rectangle added above the repeater’s original rectangle would appear above the repeater rows on your page. Repeaters and dynamic panels create their own sets of coordinates, and because this rectangle would be placed in the negative space above the original rectangle’s position of (0,0), it would continue to appear in the negative space relative to the repeater’s rows. If you wanted this rectangle to be incorporated into your repeater’s pattern, I would recommend moving it to the repeater’s (0,0) position, so that it appears at the top of your repeater rows, rather than above your repeater rows.

I hope this helps!

Hi Chelsea!

Thank you very much for your explanation. I just tried this in Axure 7 and it shows exactly the same behaviour.

In comparision to the “relative editing” (new tab with its own coordinates) the new “inline editing” confused me about the fact that there is still a seperate set of coordinates (visible at the top and on the left).

Thanks again and I am sorry for the false bug.

Kind regards
Ben