Dynamic panels not working in preview... (Time Sensitive)

Hello! I am working on an assignment for my graduate program and the prototype is due this upcoming Monday, but I have been struggling with multiple dynamic panels and hiding/showing widgets… I’ve checked and rechecked to make sure that there isn’t anything interfering with the widget, but when I hit preview, nothing happens… Can someone check over this and see what I might be doing wrong?? I’m working in the “guitars” page, in the guitar exhibit views dynamic panel in the ground level state. I can’t get the “band info Lightbox” to popup when I click on the “1950s” card in the first state (guitars page > guitar exhibit views dynamic panel > ground level state > ground level bands list folder > 1950s card box widget/folder > click on it > should open the hidden “band info Lightbox” dynamic panel, but nothing happens). Thank you in advance! here’s the rp file: <RockX_dynpanhelp.rp (2.3 MB)

Hi!

On Page Loaded, you are switching Guitar Exhibit dynamic panel to Upper Level, which has no code to show a lightbox.

image

@mbalus2 The root of your problem is the “Top Bar + Menu Global Nav” dynamic panel is pinned with “Keep in Front” option checked on, so it is always in front of the “Guitar Exhibits Views” dynamic panel, obscuring any interactions (the top 443 px of the latter dp is covered, which includes the entire 1950s card and the image with the Click or Tap event to show the lightbox.) Unchecking this “Pin to Browser” option fixes this.

You’ll also want to uncheck the “Keep in Front” option for the “pinned ground map” as it will otherwise always be kept in front of the “Band Info lightbox” despite the “bring to front” option in the Show event.


This was a little tricky to debug because the “Keep in front” on pinned dynamic panels don’t show up in the Console Trace (useful tool for troubleshooting–wish it were more useful though :wink: ) Turning on the trace did indicate that clicking on the image in “The 1950s” card had no result, so it was never being called, indicating something must be in front of it. When I hid the “Top Bar + Menu Global Nav” dynamic panel the click worked, which led me to look for how this was getting placed in front.

1 Like