[Fixed] Find/Replace within prototype broken?

I see that Axure design/devs have come around to fixing the Interaction Builder, so I just came back to give RP9 another go. However, the very first thing I did was import some stuff from an old project and look to search and replace some strings.

When I invoke the Find or Replace menu items from the Edit menu, nothing happens, so I can’t find or replace anything. This is with 9.0.0.3636 on Windows 10.

Can we file this as a known bug to be fixed asap? Please confirm.

Thanks,

-Bill

Hi Bill!

Hmm, to confirm, are you seeing that when you click “Find” or “Replace” from the “Edit” menu that the dialog doesn’t show up at all? I’ve tested on my end in build 3636 on both Windows 10 and macOS and the dialog appears to be showing up and working as expected; is it still buggy on your end? Does it happen to be showing up behind another window or offscreen perhaps (particularly if you’re using an external monitor)?

Yes. literally nothing appears to happen at all. I have a 3 monitor setup, so it could be stuffing the window somewhere offscreen in the virtual screen space which doesn’t correspond to an actual screen, but I’ve tried looking and can’t find the window when I hit Alt-tab.

I suppose I could uninstall and reinstall RP 9, but then again, if it’s storing a bad location for the window in a registry pref, it might not be cleared by reinstalling.

Hmm, how odd! I’ve been testing around on our end on a Windows 10 machine with an external monitor but haven’t been able to reproduce the issue. While there was a bug where opening dialogs and popup windows caused Axure RP to get sent behind other application windows in build 3636 and earlier, we released build 3641 today with a fix to resolve those types of issues. If you haven’t updated already, I’d like to verify whether build 3641 also addresses the issue that you’re seeing with the Find and Replace dialogs not showing up at all.

If it is still not showing up after the update, then would you mind confirming the display settings and layout of your monitors? If you right-click the desktop and open Display Settings, I believe it should show which monitor is your primary, secondary, and tertiary monitor, as well as how they’re laid out in relation to one another; confirming this setup as well as which monitor you use Axure RP on (and whether it’s in full screen mode) would help to reproduce the issue. We have seen and resolved another bug where popups such as the action list for interactions would render in the wrong place at the wrong size if external monitors were laid out in a top-down order in Display Settings (such that you would drag windows up and down to get between monitors), so this would be good to confirm whether there’s a similar issue happening with the Find and Replace dialogs as well.

We’ll keep an eye out!

Hi Alyssa,

At least one thing is no longer an issue. Build 3641 does address the Find and Replace dialog issue in RP9.

Now I just need to figure out a way to reproduce that other problem with masters in a specific large prototype in RP8 I was emailing with Chelsea at your office about.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.