Fonts isn't applied when my team member see it

hi. this is my first posting.

I’m using Noto sans CJK KR, which is google web font.
My axure RP version is 8.1.0.3381.

I already linked css file in Web Fonts tab and did font mappings too.
I can see applied fonts in the website but the problem is that font isn’t applied when my team member see the website.

I tried in many ways but I still can’t solve this problem.
Does anyone know how to solve it?

When it fails to work, are there any errors in the browser console? Does the font-family on the affected text match the font-family declared in the linked CSS?

Have you downloaded Noto sans to your system, where the font is properly displayed, while your Team member does not have a local installation of this font?

I’ve tried to work with the web fonts in the past, however found it to be working very inreliable. In the end I am telling my users to download the required font and install it. Luckily in our company there is just one font all users need to install once for all mockups.