Frustrating bug with Push Pull


#1

Once in a while I face issues with Push Pull :dizzy_face:

I have a Dynamic Panel having 2 states. 1st state is in collapsed state on clicking it changes to 2nd state which is the expanded state and all the page contents move down to accommodate the expanded state. It was working fine and I continued working in building rest of the page below. Today before a demo to my horror an hour before as I was clicking through to ensure everything is working fine and observed that the state 2 of dynamic panel is not visible as it stopped pushing the other things on the page though the state changes. I swear it was working fine as I had demoed this specific functionality as a wip to larger team.

I tried everything including removing the transitions and animations, increasing the width of panel, redid the collapse and expand state - no luck. I am only putting the post here hoping some kind soul may provide some pointers (I cannot upload the file due to confidentiality) but sending the file to support. I finally had to use a hack and did the functionality as a light box… But the issue remains…


#2

Hi!

Here is some troubleshooting for you:

  • Make sure this dynamic panel is not nested within a second dynamic panel or a group: anything that push/pulls within a dynamic panel will only push/pull other widgets in the same panel.
  • Make sure the item you want to push/pull is fully below the dynamic panel in its collapsed state.

Another thing you can try is this, which often helps resolve problems:

  • Start out with anything that push-pulls in its already-pushed state: for your dynamic panel, start it out in its expanded state (by making that state the first state in the panel) and place the item that gets pushed where you want it to be upon it being pushed.
  • Then, OnPageLoad, set the dynamic panel to its collapsed state with pull.

#3

Thanks @josephxbrick the first 2 points I had tried the alternative you suggested using OnPageLoad is definitely a great suggestion. What I finally did was that I made an additional new panel from the expanded state and using Show/Hide with Push - Pull got it working again. Sometimes Axure puts me in some rough & tough spots. Thanks for the suggestion will keep it in mind :slight_smile:


#4

Hello,
you gonna love me for this :slight_smile:
I had this issue that on and off experiencing the pull and push widget does not working. But why, some time will work? So, I figured that, automatically the dynamic panel is set on fit to content. If you create a dynamic panel, but your content is out of that area the pull and push does not work. This is happening in Axure 9. See the files attached. One is working and the other one is not.
Hope this helped.it-IS-working.rp (67.0 KB)
its-not-working.rp (67.1 KB)


#5

Hi I had this too, and realised that the offending panel had suddently stopped being set to content, so once that changed was back to normal.