Global Variables work fine in "Open Link in Current Window" but not in "New Window/Tab" at v9.0.0.3679

Hi, I think I found a bug in Global Variables.
Global Variables work fine in “Open Link in Current Window” but not in “New Window/Tab” at v9.0.0.3679.

It works fine in earlier versions(v9.0.0.3675).

Please check the attachment.

Bug_GlobalVariables.rp (51.0 KB)

Please Help!!!

I don’t think this is a bug - opening a new window will start a new session of your prototype, resetting all global variables. If you want to use global variables, you need to have a single session so that the browser can store the values locally.

Hi, Thanks for the reply.

So, why it works fine in earlier version? (v9.0.0.3675)

And, this is a definition of Global Variables in - Documentation.

Global variables and their values are accessible from every page in a project, so you can use them to pass information between pages.

That should really read ‘pass information between pages within a single session’. When you open an Axure prototype page in a new tab, you’re creating a new instance of the prototype, with all of the variables set to their initial values.

I’m afraid I have the latest version installed so I can’t test to see if this worked in previous versions, but I would be very surprised if it did, as this behaviour is governed by the browser, not the prototype itself.

Thank you for the answer, but I think differently.

It works every previous versions (even 8).
It doesn’t make sense to only have the latest version(

I don’t agree with ‘pass information between pages within a single session’.
If it is true, global variables are useless component in the project.

And I think the browser is not relevant at all.

Please check this link, you can download previous versions.


@major7sw @davegoodman
Found the same bug while working in Axure 9 and I needed this to work for a presentation I’m giving tomorrow! :confused:

Yes, it does indeed work in Axure 8:
Date-working-in-New-Window-Axure-8.rp (57.4 KB)
(Obviously, you’ll have to have Axure 8 to open this to see it working which is why I put it on AxShare.)

Here’s the same file created in 8 and saved in 9 that DOESN’T work:
Date-NOT-working-in-New-Window-Axure-9.rp (53.2 KB)

[davegoodman], this has absolutly been working fine since Axure 8, for multiple years I have used Global Variabes across new tab/pages and it has always worked. Now you are trying to claim by design it does not work this way? I agree with [major7sw], this makes global variables useless and complete nonsense.

So where are we with this bug? This is a show stopper for me.

1 Like



I already emailed to Axure support team about this issue.

They answered:

“Thank you for writing in! I’ve tested out this global variable behavior in our second most recent stable build (3675), and compared it to the behavior with the latest build (3679), and I was able to reproduce some different behavior as well. The latest build included some changes to the “Open Link in New Window/Tab” action, so that the prototype player is included in the newly opened window, so that player features like notes and comments can be accessed. This change creates a new instance of the project, so that global variables do not pass between the two opened project pages. While this behavior is expected in this case, I’ve filed a feature request regarding this global variable functionality with our respective teams to review on your behalf.”

So, I am waiting for the bug to be fixed. I hope it’s resolved quickly. :sob:

1 Like

I emailed them as well, copying this thread in, on the 27th of Jan. Here’s what they replied:

Hi Jodi,

Thanks for writing in and calling this to our attention! I have been able to reproduce the behaviour you have described and have filed a bug report for our QA team to investigate and hopefully implement a fix in the near future. We believe it may be related to the change we made to the way the “Prototype Player” behaves when opening a new window. In the meantime, we would suggest that you keep Axure RP updated with the latest release candidate to ensure you receive the fix as soon as it is implemented. This can be done within RP by clicking “Help > Check for Updates” and ensuring you have the “Check for updates when Axure RP starts” and “Include beta channel builds” checkboxes are ticked. Whilst this fix is being implemented, you could install a prior version of Axure RP (3675) to keep working as intended. This installation file can be found at the below links:



I hope that helps and thank you again for the valuable feedback! If you have any questions at all, please don’t hesitate to get in touch.

Kind regards,

1 Like

Hi all, thanks for your reports on this and for your patience! This bug is fixed in the latest release candidate build, 3686. You can download it at Axure | Release Candidate or via Help > Check for Updates (with “Include beta channel builds” selected) in RP.


THANK YOU!!! :grinning:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.