iOS text input problem when using Inline Frame

Hi folks

I have an iOS prototype that uses an Inline Frame (it allows me to emulate transitions between pages). Problem is, when a Text Field inside the Inline Frame has receives focus (in the page load event), although the iOS keyboard appears, typing doesn’t work. Tapping in the Text Field is fine - setting focus automatically is not.

Here’s a demo. Open this on your iPhone and try to type into the two Text Fields after tapping the buttons:
http://zgbnn4.axshare.com/test.html

RP file:
iOS-keyboard-frame.rp (60.9 KB)

Works OK on my Android phone. Am I missing something or is this a limitation?

Thanks
Stuart

I mocked up a similar test using HTML and JavaScript, and there were no issues, so there must be something about the way Axure is building its code that confuses iOS. Note that I tried both Safari and Chrome on iOS, and the keyboard doesn’t work in either.

Hi gingerbbm,

It looks like this issue is specific to iOS 7, but your prototype worked fine for me when I tested it in iOS 8. If you haven’t updated yet, doing so should resolve the issue for you.

We haven’t seen any major issues in iOS 8 related to Axure prototypes, but if you’d like to check how your prototype will function in iOS 8 before updating, you can look into Xcode. Xcode has an iOS simulator (currently set to iOS 8) that can be used to test your app without loading it on an actual device.

1 Like

Hi Julie

Thanks for your response. I just tested on a colleague’s iPhone 6 Plus (whoo!) and you’re quite right. It works fine.

Good idea about Xcode too. Not tried that but will now!

Thanks again
Stuart

Glad to hear it! A quick word of warning though–we are now seeing some issues in iOS 8 (darn!) if a prototype is launched from the homescreen. If you are hoping to demo your app this way at some point, you should test this workflow specifically to see how it affects your prototype.