Order of Widget Notes in Word Documentation

bug-report

#1

In my project we are currently using RP8, but we are not satisfied with the way the documentation is done. It’s a pain in the a… to get widget notes somewhat ordered in the documentation tables.

I read that you are able to simply order widget notes in RP9, so I tried that and somehow it’s not working as it’s supposed to, I guess.

This is my UI:

The Order should be Name, Prozess, Dateitypen, etc.

I set the documentation up as always:

But the result that I got is somewhat unlogical. It still ordered after row not after footnote number:

Why is this happening?


#2

Hi T-Ruben!

Hmm, I’ve tested out note behavior on my end when not using a row filter, but I’m having some difficulty testing out the row filtering as shown in your screenshot. These are the filter options I can see on my end:

image

Could you send a screenshot of your selected filter option, or let me know which of the list options you selected for the note filtering?

If possible, it could help to take a look at your project file as well. Please feel free to post the project file in this forum topic. If you would prefer not to post the project to the forum, you can send the project file to our support team by emailing support@axure.com instead.

Thank you!


#3

Hi Chelsea,

thanks for your reply.

My filter option is called “Typ” which is a value between Button, Feld (Field), Tabellenfilter (tabel filter) and Spalte (column) which are the 4 main types of objects we need to document. And we want to have them all in their own table, so I made a table where the filter option therefor is Typ equals Feld, so I get every field in that table.

To be honest I am missing a “ordered by” option where I can select a column on which I want to order.

Here’s the .rp if that helps. :slight_smile:

UI11496_Anlagendetails_konfigurieren.rp (153.9 KB)

Thanks,
Ruben


#4

Hi T-Ruben,

Ahh, that makes sense! :slight_smile: Thank you for the clarification, and thank you for the file as well! I’ve done some testing with the file, and it seems like there are some widgets in the project that seem to jump ahead of the widget’s note order when the “Include widgets without notes” filter is enabled for this filtering option. I found that disabling the “Include widgets without notes” filter allowed the note numbering to display correctly. I also found that widgets associated with the note numbers that are skipping ahead of the correct numbering are flow shapes (the flow widget “Dokumentation Besitzer” is the widget tied to note number 18, for example).

I tested out including a flow shape with a note in a new document and found that including this caused for some disordered note numbering as well when the “Include widgets without notes” filter was enabled. This behavior is unexpected, so I’ll be filing a bug report regarding this ordering issue on your behalf. In the meantime, disabling the “Include widgets without notes” filter allows for the ordering to behave as expected. Furthermore, I would recommend moving the notes contained in the flow widgets onto simple shape widgets (Box 1, for example), and removing the flow widgets from the project.

I hope this all helps! If you see any additional issues when working with your project, please let me know.