Problems with Hoefler&Co Cloud Typography in AxShare

Hi,

I can’t get the fonts from typography.com cloud service to work. I tried @font-face, I tried hosting the fonts myself, I tried enabling CORS on the server with an .htaccess file. Nothing works. I need to get this to work by Monday.

Please help.

Thanks

What errors are you getting in the browser console? Are you sure you set everything up correctly in Axure?

Thanks for making me aware of the browser console. I got a message saying:

Mixed Content: The page at ‘https://.axshare.com/#g=1&p=title’ was loaded over HTTPS, but requested an insecure stylesheet 'http://.design/fonts/629676/4F271203BB0D971C3.css’. This request has been blocked; the content must be served over HTTPS.

Dude I have no idea how to set up an SSL certificate on my Digital Ocean server. Is there any other way to fix this?

Ok, I just used serverpilot to add SSL to my server and redirect all http requests to https. I’m still getting the same error.

I GOT IT!!! For everyone who ever has problems using fonts from Hoefler & Co’s cloud.typography service in Axshare, here’s how you solve it:

  • Publish your Hoefler typefaces in the cloud.typography backend like you usually do
  • When you enter the URL the fonts will live at, make sure you add “Https://”
  • Upload them to your server like you always would
  • Enable Https on your server if it isn’t enabled already
  • Add the code snippet from Hoefler & Co’s setup to the “plugins” field of your Axshare prototype OR add the link to the fonts.css file to the “Web Fonts” section of the preview options

DONE! OMG I’m so happy right now.

J

1 Like