Repeater: Hide Filter instead of Show Filter

The basic Axure filter is a “show” filter, rather than a “hide” filter. Using the != option is OK, except that I need to set it not equal to a numeric value range.

I’m able to use this to SHOW everything between the range using this:

[[Item.ObjectID >= ‘100’ && Item.ObjectID < ‘200’]]

However, I want to do the opposite of that. I tried wrapping a few functions together, like this:

[[Item.ObjectID != ‘(Item.ObjectID >= ‘100’ && Item.ObjectID < ‘200’)’]]

That, or a few similar that I tried, didn’t work.

Suggestions? I have more hide filters that I need, so just hiding the others outside of this range isn’t an option.

Cheers.

-g

That’s just the way filters work… It would be nice to have the kind of native “inverse filter” or “repeater mask” feature you describe, and to be able to combine them.

This is also known as “faceted filtering” and is possible by combining evaluative statements in one filter, similar to what you tried (but the logic in your example is flawed.) The logic and syntax of this can get pretty tricky.

So if you want to hide everything that is “100” and has a Sub Header in your example, you would use a filter with:
[[(Item.Header != ‘YesSub’) || (Item.ObjectID < ‘100’ || Item.ObjectID >= ‘200’)]]

See this thread for a good description of this:
Repeater - Faceted filtering and ‘Remove other filters’

See this training tutorial for how to setup multiple filters:
FILTERING REPEATER ROWS

And this thread on doing it within a repeater:
Repeater filters act weird