Repeater not sorting on column named "Index"

Simple repeater with the following columns:

  • “ID” - assigned a number during creation (using it for matching on a click event)
  • “Image” - contains an image
  • “Index” - defaults to 0 (zero)
  • “Selected” - defaults to “no”

Click event increments a global variable, updates the Index on the correct row, updates filters, and sorting…based on the Index column.

Simple…but the sorting didn’t work. Banged head repeated against the desk. Double and triple checked everything.

Then tried sorting on ID (uses leading zeros)…it worked. Changed the data in Index to match the lD didn’t sort. Out of frustration (and little voice in my head whispering about reserved words) changed “Index” column name to “Fred”. Sorting on “Fred” works.

Is Index a reserved word? If so, is that referenced anywhere?

Index is a reserved property name for repeater items. This is likely the issue.

Figured that one out…is there an actual list of reserved words anywhere?

IMHO, Axure should have warned or blocked me from entering the reserved word or should have thrown an error when I ran the prototype. As it was, everything “seemed” fine, all events fired…but nothing happed.

Very frustrating…and expensive.

Hi AnneR,

There isn’t an explicit list of words or terms that are reserved in Axure RP, however I’ll definitely let our product team know that there’s interest in having this sort of information available. I’ll be submitting your suggestion of warning users whenever they’re using reserved words as a feature request as well!

If you look at the variables drop-down in the expression editor you’ll see different categories, including one with repeater variables. It may not be a comprehensive list of reserved variables but should be most of them probably.