Show widget > Treat as lightbox + Bring to front not working as expected

I have a hidden widget within a dynamic panel. I’m using an OnClick event to show it as a lightbox. However, when I click within the widget, the widget is being automatically hidden again by the lightbox behaviour. However, the lightbox behaviour is only meant to hide the widget if the click is outside of the widget. So, for some reason, the click within the widget confines is being treated as a click outside of it. Is this because a click outside of the dynamic panel container is considered a click outside of the widget? And, if so, why doesn’t “Bring to front” solve that problem? What exactly does “Bring to front” mean? Bring to front of entire page or bring to front within the dynamic panel?

Hi -
Can you post a sample file? I’m interested in learning more about what might be causing this weird behavior.
TG

I tried recreating your scenario based on your description but everything worked as expected. So either something else is going on or I didn’t fully understand your setup. Can you share a file with only the problematic widgets? It will be hard for anyone to help otherwise.

Isolating the problematic widgets can also help identify the issue. If you remove everything but the widgets you believe are problematic, and it then works, you know to look elsewhere for the real issue. You can then experiment to narrow down the cause.

Thanks for replying guys. I’m attaching the problem file. Looking forward to hearing your thoughts.
problem2.rp (930 KB)

I think it’s probably a bug. Change the lightbox background to something you can see and the problem is immediately obvious: it covers everything. Why this is happening, I don’t know.

1 Like

This is looking like a bug to me too. I’m seeing that if a dynamic panel is browser-pinned but not set to “keep in front”, it will render behind the lightbox background for its contained widgets. This causes the contained lightboxed widget to also render behind its own lightbox background.

@roginatorroginator, the “Centered container” dynamic panel on the “Schedule > close zoom” page in your file fits this description:


Until we get a fix in place for this bug, you should be able to work around it by checking that “Keep in front” checkbox.

1 Like

Thanks a lot for your help guys - much appreciated. I’ll give that a try in the meantime.

A year later and this bug still exist. But thank you for this post, managed to work around the problem.

this bug still exists

  1. I can confirm that this bug still exists. For me at least, it seemed to have something to do with nested dynamic panels. I removed the widget I wanted to treat as a lightbox and placed it outside of all my dynamic panels and it worked as expected.

I had to do some creative math to get the widget to move as desired since it is now outside my DPs, but it is a viable workaround.

Hi all,

Thank you for the reports! I’ve confirmed that this still appears to be an issue in Axure RP 9, and it is filed on our end. Hopefully using the workaround of toggling “Keep in front” on the pinned dynamic panel helps for now. We’ll post an update if this bug gets resolved, but otherwise you can keep an eye on the Axure RP 9 release notes on our site here. Thank you!