Typing inside widget

Adding text to a widget is one of my top actions, I cannot do it now just by selecting the widget and starting typing. Instead I see the following unexpected outcomes: dynamic panel is created, cursor turns to a point/draw tool. I am using a mac. Current behavior is annoying because I need to esc from the drawing or delete a panel before I proceed.

Hello! The behavior you’re describing indicates single-key shortcuts are turned on. If you want to keep them on and type into a widget, you can click [Enter] to enter text-editing mode. To turn off single-key shortcuts, go into File > Preferences. It’s the top checkbox on the first tab (Canvas).