Widget Style Manager not updating font family

We have a project we initially created with one base font but then found out we needed to change the font. The font families don’t matter; I’ve reproduced the problem using Google fonts and standard fonts like Times New Roman.

On any pre-existing pages or newly inserted custom library widgets, if I change the font family the text does not change. If I change other properties like borders or colors, the changes happen for all the existing work. But what ever I try, changing the font has no effect on the pre-existing pages.

I did many tests, but my final one was the simplest. I added a Paragraph from the Default library and a Paragraph from our custom library. I tried to change the font family, but it only updated the text in the paragraph from the Default library.

I tried to recreate the problem in Axure 8, but couldn’t. To me, this looks like a bug introduced in Axure 9. I’m using version 9.0.0.3.6.5.3. I see an update available, but I don’t have rights to install it and I don’t see anything in the bug report about a similar problem.

I ran into a similar issue trying to update styles. I THINK the work around is to delete the old style from your document…this breaks the links to the widgets in the document and the Style then appears as read in the style picker dropdown.

If you paste a widget with the new style into the document with the “broken” style links AND the style is named the same it seems to then propagate the new style to the items in the document.

Managing styles in Axure is still confusing, but I was able to have some success with this method when brining new styles into an existing document. It seems that Axure give higher priority to the existing style than to the new style brought into the document.

Hope this helps.

1`. How do you break away the old styles?
2. If this is the same problem, I had it in a brand new document.

I heard from Axure and have a better understanding of the Widget Style Manager now. This can be closed unless someone can tell me if there’s a way to do a project-wide replacement of one font for another.

You need to delete the style in the document (from the style manager). Then you elements that have that style applied will appear with the existing style name (but the text for the style will be red). Then bring in an element with the exact same style name that has the desired font (you can paste it into the document). This should then link the broken styles in red to the new style you have brought into the document.

1 Like

That’s not really the issue. As I posted above, I had some long email conversations with Axure Support and it turns out my team has been using Axure styles wrong for nearly a year. We assembled a team with various expertise for a new project, but unfortunately we were all either newbies or totally new to Axure.

So now I’m finishing up a 12-day vacation and hoping my team has been following the updates I’ve been trying to teach them. Axure Support also submitted about a half dozen feature updates I’d like to see to make Axure and Axure Styles work more like other web development tools. In my mind, the Style Manager should act move like a style sheet; but the way styles get the * when you make a local change just breaks that behavior.

Good tool Powerful tool. But it could stand a few million updates to work better for experienced web developers. Just my exasperated two cents.

2 Likes