Axure 9 and 8 on Catalina does not save files

technical-troubleshooting

#1

After clicking on the save button, I see an error window. MAC OS Catalina reinstalled 2 times. What should I do?

Report log
Can’t cast from NSLocalSavePanel to MCocoa.NSSavePanel


#2

I’m having the exact same problem on Catalina 10.15.1 (19B88)


#3

I think this issue is related with some of us not being able to add apps to that Files and Folders section on Os X Catalina. Noticed the plus and minus signs are disabled. Even if the section is unlocked.


#4

Even if the + / - where grayed out (disabled) i managed to add Axure Rp 9 to the Files and Folders section by adding it to the Full Disk Access section (just by dragging the app on the box) then it appeard on Files and Folders, but still can’t save Axure files on Catalina. The workaround for me was to install Parallels on my Mac so now i run Axure Rp 9 on windows, on my mac


#5

Thanks! I just downgrade to Mojave :’(


#6

Hi guys,

Thanks for sharing the workarounds that you’ve found so far. While neither is idea of course, we’re glad that at least you’re able to continue working with Axure RP 9. Our QA and dev teams are aware of the issue; from our investigation so far the issue seems to specific to some machines and not all (we can’t reproduce it so far ), but it does seem to be specific to macOS 10.15. Users of other apps are also running into issues after upgrading their OS, so the root of the issue may be with macOS Catalina. We’re still working on gathering more information on the issue to see what can be done on our end, but if anyone happens to notice a pattern or any helpful tips please feel free to send them our way!


#7

Same issue here,
I can’t change the fonts, I can’t manage the widget styles, I can’t import from an RP.
58 19

it is not an option for me to install another operating system to fix this.
Help?


#8

A workaround i found for this problem

  • Open Axure Rp 9 on MacOs Catalina
  • Create new file
  • Upload as untitled document to Axure cloud (since save or save as are not an option)
  • Download untitled document from Axure Cloud
  • Rename the untitled document to whatever name you want to use.
  • Open in Axure Rp 9
  • Now you can work on renamed document and edit as needed.
  • Also you can save your changes locally

Still ’save as’ will not work. i think It’s basically a painless workaround even if it forces you to create an Axure Cloud account, because it can be done in 2 minutes and prevents one from downgrading to Mojave, while someone finds a cure. Also i think this is easier than to use Axure Rp 9 on Windows using Parallels. Less windows and less CPU used.

I really don’t know if one could manage the widget styles, A problem @alinbuda mentioned.


#9

SOLUTION FOUND :grinning:

  1. Reset the PRAM on your Mac
  2. Reset the System Management Controller (SMC) on your Mac

To reset PRAM follow this article: https://support.apple.com/en-us/HT204063
To reset SMC follow this article: https://support.apple.com/en-us/HT201295

Notice on reseting SMC that the process changes depending on your computer model. Mine is a MacBook Pro 2018 which has a T2 security chip so I followed the particular instructions for that model.

I have a gut feeling that option number 2 (reseting SMC) did the trick, however since I did 1 (reseting the PRAM) and then 2 (reseting SMC), I’m not quite sure which of the 2 options above solved the problem.

But now I can save Axure new docs.
Hope this helps. Cheers -


#10

Thanks for sharing the solution that you found @lmuzquiz! This one has been tricky as it doesn’t occur on all machines and thus reproducing the issue and diagnosing the cause is tricky. If others are still running into this issue and resolved it, then it would help us to know whether the same solution of resetting PRAM and SMC on your Macs was what did the trick (or if you’ve tried that and it didn’t work, that would still be useful to know as well!).