Axure Share on Android Device Scaling Issues

I know this type of issue has been discussed many times (sorry) but I’m having problems viewing my Axure prototype (via AxureShare) on the target mobile device it looks huge! Can anyone help me?

Target Device: Android mobile: 1280X720 px with 320 DPI (XHDPI), scale factor 2
Axure prototype:

• I created a wireframe 720X1280 px (will be used portrait only) size.
• I’ve checked the “include Viewport Tag” and tried setting it to: “device-width” and 720 … but sill appears too large a scale on Android device.
• All other Mobile/Device settings are empty
• Not using Adaptive views (yet).

Any ideas?

Hi Alan-Trow-Poole,

It sounds like the device you’re viewing your prototype on has a scaling factor of 2–is this right? In this case, adjusting the “Initial Scale” option in the viewport tag options to “0.5” might help. This is because if your device is applying a scaling factor of 2, the effective screen width might actually be half of it’s listed resolution, which would be 360px instead of 720px. You can check the size in px of the window your prototype is being viewed in by setting a widget’s text to “[[Window.width]]” right when the prototype loads (e.g. in the “OnPageLoad” event).

Another thing you could try is keeping the initial scale at “1.0” but then resizing your prototype to be 360px wide (using adaptive views here might help). If you’re interested, you can read more about the viewport tag and initial scaling option here:

If those approaches didn’t do the trick, would you be able to post a copy of your RP file so I can get a closer look? Feel free to remove any proprietary information before uploading it. TY!

Thanks for that detailed (and prompt) reply, much appreciated. I’ll try your suggestions and let you know if they work for me. Thanks for the offer to upload my RP file.