Background Color Setting Failure?

I’ve had this problem several times. I don’t know how to reproduce it.


Hi afei929,

It sounds like you find you’re unable to set the background color of a widget and this happens at random, does that sound correct? I realize you mentioned you don’t know how to reproduce the issue, but if you’re able to recall any specific steps you took prior, e.g. adding a widget, switching pages, etc., that’d be a big help. Thanks!

test.rp (42.3 KB)

See the attachment please.

Hi afei929,

Sorry for the delay! I am also unable to change the fill color of the widget in your .rp file. Am I right to assume that this is a custom shape made with the Pen tool? And if so, could you let me know how you removed the left and right borders of this shape? I believe this is the root of the issue, as changing this shape to a default shape helps retain the fill color (right-click > “Select Shape”), so any additional details you’re able to provide will be helpful. Thanks!

Hi Jane,

I know how this issue occurred finally.

S1: Add a box, and set the border visibility.

S2: Move the cursor to the edge of the widget and double click the mouce. It will enter the point edit mode.

S3: Add a point, the background color will disappear and can’t be set.

The above operation is not my intention. What I want to do is add text to the widget. In the new version, double clicking in the center of the widget will enter text edit mode, double clicking at the edge of the widget will enter point edit mode. When the widget height is small, It is often mistaken to enter point edit mode.

Edit mode is not commonly used, I recommend removing the double-click mode. Text editing is very common, I suggest that you can still type text directly in the widget just like the previous version.

@Jane_Axure Please pay attention to this issue.

Hi afei929,

I missed this one on my queue - really sorry about that.

After following your steps, I was able to reproduce the same issue, and I reached out to our teams as to whether this was a bug or expected behavior. While I agree it’s unexpected where the fill for the widget goes missing, this is the expected behavior for now. When converting a shape with non-adjacent borders to a custom shape - which is what happens when you enter point edit mode - each border line becomes its own shape, but they’re still represented as one shape because they’re united. You can break the shapes apart by right-clicking on the shape and selecting “Transform Shape > Break Apart”.

As for text editing mode vs point editing mode, you do have the option of typing directly into the widget, like in Axure RP 8. If you go to “Axure RP 9 Beta > Preferences > Canvas” and de-select the “Enable Single Key Shortcuts” checkbox, this will bring back the ability of typing directly into the widget to enter text, without having to double-click. If you wanted to keep single-key shortcuts (e.g. when you press [T], click-drag to produce a shape with text pre-populated), but would prefer not to double-click, you can press [return] on the target widget, and this should also allow you to type directly into the widget as well.

Please lmk if you have any thoughts about this, or have any questions. :slight_smile:

1 Like

Hi Jane,

Thank you very much for your reply. Your method is helpful for me.