Cannot inspect items


#1

Hi, a colleague shares some designs with me, and almost 50% of the time I am not able to inspect them. Totally broken experience for using the project that might actually be a great tool…

When I report him the issue and he updates the document, it seems it works fine, but randomly, after a day or two, I might get it again.

Error I see in console:
Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘https://l5tdwi.framed.axure.cloud’) does not match the recipient window’s origin (‘https://app.axure.cloud’).

as well as:

Access to XMLHttpRequest at 'https://d1icd6shlvmxi6.cloudfront.net/gei/L5TDWI/expo/f6/cb/20/f6cb201438ca4fdf8af5b9a890698087/artboards/ab_2053b8a9-86ca-4c17-9582-3761be6c5d7d/revision_0005/asset/asset_cdd1ec15-2861-417f-b51d-814690424654.json?token=e9d301e2a0c53fc0118bdb6e4fe7ce61' from origin 'https://l5tdwi.framed.axure.cloud' has been blocked by CORS policy: The 'Access-Control-Allow-Origin' header has a value 'https://l5tdwi.axshare.com' that is not equal to the supplied origin.
messagecenter.js:296 dispatched to https://l5tdwi.framed.axure.cloud/#id=2053b8a9-86ca-4c17-9582-

P.S. and yeah, fix the

dispatch to ‘some long url’

spam in the console :slight_smile:

Have a nice day


#2

Hi asjustis!

The Inspect feature is only available when viewing your project within the Axure Cloud web app. So if you’re visiting the project’s public url - which would look something like <abc123.axshare.com> - then it’s expected that you wouldn’t see an option to Inspect your projects.

Based on the console errors you included above, I think you might be viewing the public url which would explain not having access to the Inspect feature.

If you think that’s not the case - i.e. you have access to the Inspect feature and it’s just not working - or you still have questions about this feature, feel free to shoot an email out to support@axure.com

Thanks!
Tuomas


#3

Hi Tuomas,

Yeah, I noticed these ‘public urls’ do not allow going straight to inspect mode, that’s not where I try to inspect. Unfortunatelly, this happened while opening documents through app.axure.cloud . I checked now - all docs seem to be okay, but I never know when it can happen again.


#4

Hi asjustis,

Dang, that’s unfortunate. If you’re viewing the project within the Axure Cloud web app - that is the url is <app.axure.cloud/…> - and you’re not seeing the Inspect feature then that’s a problem. It sounds like this is working for you now, but if you end up in this state again the best course forward would be to document as much as you can - screenshots of what you’re seeing help - and reach out to support@axure.com for further troubleshooting.

Thanks again!