Can't view embedded Axure prototype with password in Jira

Hi! Not sure if this question belongs with Atlassian or Axure, but I figured I’d try here first.

We’ve installed Axure for Jira so we can embed Axure prototypes in tickets.
I’m having trouble accessing the prototype in the ticket.

Our prototypes have passwords, and when the password is entered, and I click “View Project” the login screen doesn’t go anywhere. It doesn’t even say there was an error with the password.
Is there a configuration required for prototypes with passwords?

Thanks.

Hi ally0!

Sorry to hear about this. Can I get more information about the issue?

  1. What browser are you using for Jira?
  2. Are you using Jira Cloud or Jira Server?
  3. If on Jira Server, what version are you running?
  4. On the Jira ticket with the embedded Axure prototype, please right-click on the page in Chrome, select “Inspect”, switch over to the Console tab, and submit the pw for the Axure prototype. Can you share with me any errors you see from the console?

Last, please feel free to email our support at support@axure.com for more direct assistance on this issue. We can further troubleshoot from there. Thank you!

Apologies for the late reply.

I’m using Safari. But I just tried viewing the prototype in the ticket on Chrome and it worked there.
We are using Jira Cloud.
I did see this error in Safari (prototype ID removed): [Error] Blocked a frame with origin “https://[prototype].axshare.com” from accessing a frame with origin “https://app.axure.cloud”. Protocols, domains, and ports must match. (x2)

Thank you!

Thanks for the info - that was very helpful!

it sounds like your Safari browser has “Prevent cross-site tracking” enabled, which is why the entered password isn’t getting saved. This is a feature in Safari where it blocks cookies and other data for more privacy. You can change this setting by going to “Preferences” in Safari and disabling the “Prevent cross-site tracking” checkbox under the “Privacy” tab.

I hope this helps! Let me know if that doesn’t resolve the issue, or if you have any other questions.