[Fixed] Copy and pasting from one page to another

bug-report

#1

hi there,
I am using Axure RP9 (have been using 8 for 3 years) and I copy a lot form one page to another (a combination of buttons with interactions showing pop ups for example) and for what ever reason copying and pasting has now become VERY temperamental and doesn’t work the majority of the time. Am I doing something wrong here? Anyone else having an issue?
Thanks


#2

Can’t say I’ve experienced this - and I’ve pasted quite a bit in the past. Does it happen randomly or with a specific project/page?


#3

I experience the same issue. In my experience the following applies:

  • Selecting ‘copy’ and ‘paste’ from the contextual menus seems to work better than using keyboard shortcuts.
  • It seems to be impossible to copy from one page to another if the copied items contain hidden elements.
  • The clipboard seems to be cleared every time you past something (especially interactions), so you can’t paste multiple times in a row.

Using Axure Pro v9.0.0.3654 on macOS Mojave 10.14.5


#4

This is exactly what happens to me. It is very time consuming and frustrating (keyboard has been bashed more than once :joy: )

I will try copy and pasting from the contextual menu, hopefully that will stop some of the frustrations.

Thanks!


#5

I’m having the same problem. For me it just started happening a week ago. Sometimes I can copy and paste between pages, sometimes I can’t. Sometimes, if I copy and paste onto the same page, then cut, it will paste on another page, but right now, I can’t get that to work either…

Context menu v. Command/Ctl C makes no difference to me.
Even using Paste Special > Including Locked Widgets doesn’t help


#6

I have found that cutting and pasting sometimes works but I haven’t quite figured out a pattern of when it does and doesn’t work yet. It’s very frustrating!


#7

Yes! Same issue here. I began to realize it about a week ago right before the July 4th weekend. I think I have narrowed it down to the pages needing to have the same zoom percentage. Very odd and frustrating for sure.


#8

I am struggling with the same thing a lot. I am using Axure for many years and copy pasting

  • colors (previously it was just a click on the fill dropdown, now I need to double click for recent or add to favorites),
  • interactions (I need to click now in the interaction header and use context menu),
  • elements (I am not sure why this does not work, but tricks me many times even if I use context menu to make sure that I copied. I tried with or without isolate or element selection or many other things - cannot figure out why it fails, but fails multiple time per minute),
  • texts (sometimes it feels something else got pasted from a different clipboard (?) - I cannot wrap my head around the new logic)

Everything above worked fine up until version 8.
I love Axure 9, but this really slows me down. The most frustrating is the element copy whenI close a page or dynamic panel after copy, but then I need to go back and find the element again.

I do my best to figure out - let me know where to share the logs, feedback, whatever is needed to fix this issue. Copy-paste is really frequent.


#9

Hi all,

Thanks for posting what you’ve been able to find about the copy/paste issue thus far! I’ve just filed a bug report for this issue on our end, but as of yet we haven’t identified what specifically seems to be triggering the issues with cutting/copying and pasting widgets. To help us narrow down the issue, would you all mind confirming your OS? So far the pattern seems to be that this happens on macOS 10.14.5 with build 3654 and higher of Axure RP 9, based on two confirmations so far; if anyone is on a different OS or version of macOS that would help to confirm the range of the issue.

If you could also verify whether the issue seems to be worse when using keyboard shortcuts vs the context menu, as well as whether it’s worse when copying between pages rather than the same page, then that would help. Also if you notice whether it’s specific to a particular file or type of file (e.g. .rplib or .rp), or to specific types of widgets (e.g. imported from Sketch or drawn vector shapes) then that would also help to guide our troubleshooting. Thank you!


#10

OS:
10.13.6

Keyboard vs Menu:
Both don’t seem to recognize the command until a few attempts later

Same vs Different Pages:
Only between different pages. Ability to copy&paste on the same page works fine

File Type:
.rpteam

Having no issues with a local .rp file. Works as expected.

Widget Type:
Using only Axure widgets & components


#11

I am having the same problem and I’m finding it is completely debilitating. I can cut or copy an item on the same page then go to another and it won’t paste. It will also fail between different states of a dynamic panel. It seems to be random however the simple copy and paste is problematic most of the times. I am using MacOS 10.13.6, and build 9.0.0.3654 on a mac pro 5,1.

Is there any way we could download an older build as it wasn’t happening in the last version I was running which I have been keeping up to date because of the memory leak issues.


#12

I reverted to build 9.0.0.3653 and the copy/paste issue doesn’t exist


#13

OS:
MacOS v 10.14.5
Macbook Pro 15" touch bar

Keyboard vs Menu:
Both don’t seem to work, the only thing that some times works is cutting and pasting.

Same vs Different Pages:
It happens between pages and between different state panels on the same page.

File Type:
.rp

Widget Type:
All axure libraries and custom created with in axure.


#14

Awesome guys, thanks for all your input! We’re still investigating this on our end, and though we’re able to reproduce it it’s tricky to pinpoint the exact cause due to the intermittent nature of the bug. It does seem to only be affecting Macs, and just Axure RP 9, and affects pasting between pages as well as on the same page within groups/dynamic panels. We’ll keep working through it on our end, but if you happen to notice specific patterns as to when/how the issue is being triggered please feel free to share!

Thank you @allanz for letting us know that you’re not getting the issue anymore after rolling back to build 3653. If anyone else would like to try rolling back to that build for the time being, I’ve provided the links below. As a heads up, we would only advise this if the fixes applied in build 3654 (e.g. fixes for Mac memory leaks) aren’t crucial to your project currently.

3653 for Mac


#15

I’ve been experiencing this for a while. It is beyond aggravating. Here is my two cents…

What I have found is this (I can reproduce this): If you have an item (seemingly any) in focus on the page you are copying from OR to upon attempting to paste, the item you are pasting WILL NOT appear. However, if neither page has an item in focus upon pasting, the object will paste as intended (using keyboard commands or the menu).

This is significant because the default behavior in Axure 9 is that when you copy something, that item remains in-focus on the page where it exists. So you need to click out of that object (but not on anything else!) before pasting on your destination page (and not on anything on that page, either!) in order for the paste to successfully occur.

I am running Axure 3654 on MacOS 10.14.5, ftr.


#16

Thanks for this comment! Making sure I have not got anything in-focus on either page seems to work and has allowed me to copy and paste. Albeit still VERY annoying.


#17

Hi everyone,

Thank you all for your reports and the information you’ve provided! We believe we have a fix for this issue, which has been included in the latest release candidate, 3657.

If you’d like to give the RC a try, you can download it from Axure | Release Candidate or via the updater in RP (Help > Check for Updates > with “Include beta channel builds” selected). Please let us know if you’re still running into any issues with pasting on this new build. Thanks!