Font Awesome 5 Solid, Font Weight Changing from 900 to 400

Hi ,

I am using the FA Solid In a few places in my axure file … I published them and the fonts are not rendering properly. The font-awesome solid font-weight is changed to 400 where as the weight has to be 900 . Here is the test link i created.

https://z4mow1.axshare.com/#g=1&p=test

I am having this problem on firefox. My team has reported the problem on other browsers. I tried using the link from axure guru as well as the link from FA website and none of them worked.

Axure Guru FA Webfont Link

https://use.fontawesome.com/releases/v5.0.12/css/all.css

Any help to resolve this issue is appreciated.

For anyone following up,

Imaverick wrote into the help desk about this, and we were able to resolve the issue by having the user first install the latest OTF font files from Font Awesome 5 (now version 5.1.0):

And then adding a font mapping entry to map the Solid icons to Solid and the Regular icons to Regular. To clarify, we do have a known issue on file where the Solid icons don’t render in the output using the CSS link for Font Awesome 5 (they revert to Regular), so you’ll need to map the Solid icons to the Solid font weight in the Font Mappings tab of the HTML generator, as well as adding a Web Fonts entry. Here’s a screenshot of how the font mapping should look:

If anyone is running into a similar issue and the above steps don’t help, please write into the help desk (support@axure.com) with your RP file so we can further troubleshoot. Ty!

1 Like

Hey Jane,

What are the recommended settings for using Font Awesome 5 Free in the Axure 9 Beta?

My font works OK locally, but I’m having issues sharing my prototype resulting in the following:

My current settings are as follows:

Hi cheics,

As a first step, please remove any Font Awesome 5 Free/Brand fonts from your system, and then reinstall the new font files (v 5.5.0) from the Desktop version:

https://fontawesome.com/how-to-use/on-the-desktop/setup/getting-started

After installing the OTF font files from the above link, open up your file, go to “Publish > Generate HTML Files > Fonts”, and then update the CSS link to reflect the new version:

https://use.fontawesome.com/releases/v5.5.0/css/all.css

Now, it looks like the newer versions of FA 5 have fixed the issue of the Solid icons not rendering in the output with Axure RP, so please remove the Font Awesome 5 entries you have in the Font Mappings tab.

Please also note that Axure RP does not work with the ligature method of adding Font Awesome 5 icons, i.e. typing out the widget name. You’ll see this working on the Axure RP canvas, but when published, the icons will not render properly and will instead show the name of the icon you are referencing. To resolve the issue, you’ll need to copy & paste the icons directly from the Font Awesome icon site into Axure RP:

https://fontawesome.com/icons?d=gallery

If this still isn’t working for you, please post your .rp file here so that I could investigate further. Thanks!

1 Like