Font Awesome Widget Library for RP 8 (Icon Fonts)


Please, FontAwesome 4.7 version for Axure 8. Thank You!


Waiting for the latest version as well.

BTW - FontAwesome 5 is in beta now and for those who participated in their kickstarter crowdfunding, the beta fonts are available to download on github. So will be interested in seeing if that will work in Axure.



Hi guys,

We updated the Font Awesome widget library to V4.7 in the original post. Let us know if you have any questions!

Note: If you're seeing the following when dragging and dropping the icons onto your page:

For Mac:

For Windows:

This means the Font Awesome V4.7 font hasn’t yet been installed on your machine. This may happen if you’ve never had the Font Awesome font installed before, or you have a previous version (V3.2.1, V4.5, V4.6) of the Font Awesome font installed. Please refer to Step 1 to install both the .ttf and the .otf font file for V4.7 of Font Awesome.


Where is the rplib download link?


Hi pfernandes,

We were running into an issue with file attachments in the recent forum migration, but we were able to restore most of them. You should now be able to find and download the FontAwesomeV4.7.rplib file in the original post again.

Please let us know if you run into any other issues or missing file attachments!


I am trying to see these font awesome icons on my mobile but no luck. I can see on my local machine on which I am working.


Hi pradipkhekare,

Would you be able to upload a copy of your RP file and a link to your prototype URL? From you description, it sounds as if a setting in the HTML generator is misconfigured (e.g. the Web Fonts link). We’d be happy to help take a look. Thanks!


First of: Very nice library,
are there any plans to update the library to the current version 5.0.7?


Yes, please!

The font naming issue with latest fontawesome version is a mess when we have icons from both versions in axure file.

RPLIB would be very nice to have. Copying from fontawesome website and then changing the font in Axure file is a pain!


Hi :slight_smile:

Please… is there anyone who can explain me the right way for installing Font Awesome 5.0.10? I try to install it on my web with Fontexporer. I am not able to bring that font on my screen… every time it shows ma a “?” instead of an icon. Last time I installed Font Awesome 4.5… that worked without problem!

Thanks for help!



Hi Christian!

I’d first like to mention that the Font Awesome widget library in this forum thread is for version 4.7 of Font Awesome. If you’re using version 5.0.10, the icons from this widget library may not work with the Font Awesome 5.0.10 font.

With that in mind, please download the Font Awesome 5 ZIP file from here:

Unzip the ZIP and go inside the “use-on-desktop” folder. Once inside, double-click to install the “Font Awesome 5 Brands-Regular-400.otf”, “Font Awesome 5 Free-Regular-400.otf”, and the “Font Awesome 5 Free-Solid-900.otf” font files. At this point, please ensure that these fonts have been properly installed on your machine by opening up your Font Book (for Mac), your Font list (for Windows), or your FontExplorer app. If you had Axure RP running during this time, please exit it so that it updates with the installed fonts.

Once that’s done, you’ll want to copy the icons from the site below (since there isn’t yet a Font Awesome widget library built for v5.0.10):

Here’s a screenshot to demonstrate where you can copy the glyphs:

And then paste the icons into Axure RP. If the icons are rendering blank or with a question mark, make sure the proper font is selected. For the “accessible-icon”, for example, it looks like the selected font for this icon should be “Font Awesome 5 Brands”.


Hello Jane!

Thank you so much for your help! Now it works :slight_smile:
Wish you a good time…

Greetings from Frankfurt


Hi there,
I have just switched to using a Mac (about two days ago), and can’t figure out how to install any fonts. I’ve downloaded Font awesome, and have tried putting it with my axure libraries, but whenever I try and load it I can’t access them (they are greyed out).

I am bound to be missing some easy step. Help!


To install fonts on your Mac, open Font Book from your Applications folder. Then from the File menu of Font Book, choose Add Fonts… or press COMMAND+O. Then navigate to the font files you downloaded and selected them.

In many cases, depending on the font file type, you can simply double click the font files and they will be installed automatically.

Once they’re installed you should be able to selected them from the font options in Axure when editing text. They are not added as a library file like it sounds you tried, that’s not how it works. If Axure was running when you installed the fonts you might need to restart Axure before you’ll be able to see them as an option.


Hi Jane, I am still having this problem on Windows 10. I see the icon while dragging it, but it turns to a rectangle after I drop it. I have re-installed the ttf and otf. I have only ever used 4.7. Is there anything else I can try?


I figured it out. I was using the wrong library to select the icons.


Any plan to add a widget library for v5?


Hi aguiguis!

I’ve just updated the original post with the widget library for version 5 of Font Awesome.


Thank you, Jane.

I’ve followed your instructions as precisely as possible. It works well in terms of pasting icons from a library. Unfortunately, it doesn’t work reliably if you use ligatures. Meaning, you just type the icon’s name and it appears. It is ok in Axure’s editor. Thought, still unpleasant with icon names containing a hyphen. The problem appears in preview mode or if you make an HTML export. Safari doesn’t display the icons at all. Chrome messes up all icons with a hyphen. Firefox does the best job. But it still has problems with some (!) icon names containing a hyphen.

I’m not sure what the reason for this problem is. The only change I did lately was an update of OS X to Mojave.

I’m desperately looking fo a solution cause I use ligatures in all my repeaters. Any ideas?

Thanks for your help,


Font Awesome doesn't show up in Browser under OS X Mojave

Hi Bernd,

Ah, apologies for not mentioning this in the post. While Font Awesome 5 now supports ligatures, Axure RP does not, in that they render in the Axure RP tool, but not in the output. To get Font Awesome 5 icons to render in the output, you’ll want to copy & paste the glyphs rom the FA website or use the widget library (from this post).

I can see that this would be hindering for your workflow, though, and I’ll pass this along to our product team to see if we could support FA ligatures in a future release.