Getting Axure 10 to work in app/preview/and cloud with Fontawesome 6

I hope someone can help me here. I used to use fontawesome 5 with Axure 9 (i don’t think it matters that it is 10 now). It really worked well because I had a CDN that i can add to the publish/font page.

But with fontawesome 6, they have sunsetted the cdn option and force you to use kits. I have no idea how to get this to show now on the preview and cloud. Anyone run into this issue and have a solution??

In Axure Cloud, in each project’s Advanced tab you can add the following “plugin” script (replace [YOUR KIT ID]):

<script src="https://kit.fontawesome.com/[YOUR KIT ID].js" crossorigin="anonymous"></script>

Apply to all pages and all new pages.

1 Like

Thanks @jyoung! I am going to try this!!

I did try your suggestion @jyoung, but still not working not sure why. I am hoping someone else or you figured it out. I am attaching my RP file… I have fontawesome 5 and fontawesome 6 there. Fontawesome 5 works because the way I included it as a webfont. I tried the “plugin” route for Fontawesome 6 with my kit info but it doesn’t seem to work. Any help would be appreciated…

RP file attached
Link to Axure prototype: https://dvwn9g.framed.axure.cloud/page_1.html

hi all,
I just wanted to close the circle on this. I found out what I needed to do in order to get the fontawesome to work. I had to include the following 2 fontmapping additions:

After that, it started working. Let me know if you had much success with or without this.