Importing pages into library: Manually changed format on widget reverts to applied widget style format

Currently, I have to convert a team project into a team library.
I do so by creating a new team library and using File > Import from RP file
I import everything including widget styles.

This works very well except for one issue:
Widgets were the style has been changed from the applied widget style without creating a new widget style revert back to the properties of the widget style upon import.
(Changed styles without a widget style are indicated by star behind the applied widget style).

E.g. I have a rectangle that has widget style “Rectangle” which has a border of 0 pt. Manually the border of the rectangle has been changed to 1 pt.
If I now import a page that contains the rectangle widget into a new library file, then the rectangle will revert to the widget style “Rectangle” settings with a border of 0 pt.
What I would need is that the rectangle remains with a border 1 pt that as it has been manually applied to the rectangle in the team project.

Is there any way to achieve that?

Side note: I tried this with non-team project files and in Axure 8, but behavior was always the same.

Hi janschulze!

I’ve tested out importing standard and team project files into a team library in Axure RP 9, but unfortunately I haven’t been able to reproduce this behavior with widgets’ custom styles. If you haven’t done so already, please ensure that you’re running the latest build for Axure RP 9 by navigating to Help > Check for Updates. If the issues still persists when running the latest build, please send along the following information:

  • What operating system are you using?

  • To clarify, does this only happen when importing a team project file into a team library, or does it occur in other circumstances where team projects are not used?

  • If possible, please send along a sample of the file being imported and the library being updated. If you would prefer not to share these on the forum, please email us at support@axure.com with these files so that we can continue investigating the issue there.

Thank you!

Hi Chelsea,

thank you very much for your help!

I am using Windows 10 and my Axure 9 is up to date.

I recently converted the rpteam file from Axure 8 to 9.
I also tried importing the Axure8 RP into a new library in Axure 8 but have the same issue.
I also tried importing a non-team rp into a non-team library in both Axure 8 and 9 and have the same issue.

I now tried reproducing the issue I am having with a fresh rp and rplib in Axure 9. Like you, I couldn’t reproduce it in that way. The changed styling of a rectangle (border = 0 with the connected style remaining set as default border = 1) was correctly imported into the new library file.

However, so that you may be able to reproduce, I cut a tiny part from my problematic rp file:
import rp into library.rp (127.1 KB)

When I import this RP into a new library, the inner rectangle changes from border 0 in rp to border 1 in rplib. Or the other way around when I import all widget styles: Outer rectangle changes from border 1 to border 0.

Could you check if this also happens for you?

Many thanks!
Jan

Hi Chelsea, could you look into this issue again? Thank you!