Inline frame connects to vimeo/youtube video but it won't play using a button onclick event

accept button_inline frame.rp (67.0 KB)
Hi,
I have a button I’m trying to get to play a sound - using an inline frame and a video I uploaded to vimeo. (The video is just a white screen with the audio I need.)

I set up my button to link to the inline frame, which links to the vimeo video.
All well and good, it is clearly connecting to vimeo file as I can play the video when I click it - however, it is supposed to be triggered by clicking the button… and it won’t do it!
It “flashes” a little when I click the button, like it’s trying to do it, but it won’t play.

I found several sources that said to add “?autoplay=1” to the end of the file path, but this made no difference.

I’ve also tried this in youtube as well with the exact same results.
Help!!!

-EvanCC

Hmm, what browser are you using to test? On my end it looks like adding “?autoplay=1” to the end of the link that you’re opening with your button does the trick in browsers that allow it (e.g. Firefox, Safari). For Chrome specifically (which seems to have updated to prevent videos with sounds from autoplaying) it looks like the button won’t play the sound initially, but if you click away to a different tab and come back then it works if you’ve added “?autoplay=1” to the end of the button’s URL. Does that do the trick for you?

Got it! …I also had to update Firefox, but it works now.
Thanks!
-E

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.