Interactions do work when previewed - but not when published


Hi all,

I am working with axure (8) for several years - never stumbled over that problem.

In a very symple prototype (no dynamic panels, nothing overlapping …):

  • when previewed the interactions are working.
  • when published (HTML, locally) the interactions are not working. And thy are not visible in the console.

Did I do someting stupid that I have never done before?

Best regards,



Could you post your .rp file here? Hard to offer specific help for this otherwise. If you can’t post, I recommend emailing and attaching your file. They can help you confidentially.

Are you using the same browser when previewing directly vs viewing published HTML? Is it Google Chrome? You need to add the Axure RP Extension for Chrome to run prototypes locally with Google Chrome.


Hi mbc66,

of course I can. But you will be disappointed: There is nothing special with it.
But at least I put 2 screenshots inside that are documenting my observation.

Thank you - one of your hints already is helpful: As I do normally I used Firefox to check the problem. With MS IE everything is fine?!

Any hints on problematic Firefox settings that only affect published prototypes?

noInteraction.rp (108.0 KB)


Interesting. When I tested your prototype by publishing locally and opening in Firefox, it worked. Then I updated Firefox to latest version (68.0.1 on Win10) and it no longer worked. I also created a new prototype with button to link to “Page 1” (just in case Firefox was blocking new windows/tabs) and that does not work when running locally but does work when previewing and does work when published to AxureShare. For grins, here is your prototype on AxureShare, which works fine for me in Firefox :

So it looks like Firefox has changed something to block local file:/// pages from running. Might want to submit this as a bug to and see what they say about it. Until then, you might just need to use a different browser for running prototypes locally.


Feels good not to be alone. Exactly my Firefox version.
Good to know this is an issue so I can inform my customers just in case.

I will submit this bug.

Thank you mbc66,


I submitted ticket #227896 for this exact reason last week. Firefox no longer works with a published file. From what I can tell, the Axure prototype does not completely download all the necessary files. I noticed that glyphicons no longer show on bootstrap sites when viewed locally as well. So this is indeed a Firefox bug… which is why I submitted bug #1566504 to Mozilla. So far no fix, and my IT department is slated to re-install Firefox this morning to see if we can get Axure working again.


I have the same problem now. I am a heavy axure user and everythin worked fine till last week.
The problem occurred this week for the first time after the last axure update.

  • It happens only in chrome (Version 110.0.5481.177).
  • Any link works in preview but not in the local export.
  • Any link works on axshare.
  • No problem in safari.
    Am i the only one who noticed this?

This is Axure RP10 btw.


Hi @evadu,

Could you post your .rp file here so we can further troubleshoot? If the file contains sensitive content, you could send the file over to our support team at Thank you!


Hi @Jane_Axure,

sure. Here ist my testfile:
test.rp (92.4 KB)
The links in the dropdown-menu didn’t work. I tried a simple link in the middle from the rectangle to page 2 or the textblock to page 1. And those fail, too.
Thanks for looking into it!



Hmm your file is working on my end - I’m hovering over the component dropdown menu and clicking to go to “Page 2”. The placeholder “simple link to page 2” also works to go to Page 2 on my end. I tested in 3893/3894 and with Chrome v110.0.5481.178. Can you let me know the build of RP you’re running (“Help > About Axure RP”)?


@Jane_Axure ,
That is interesting.
My build is (x64)



The plot thickens! Would you be able to send us a screen recording of what you’re seeing on your end in preview? You could send that over to so we can further troubleshoot the issue from there. Thank you!


To follow up on this,

We were able to repro evadu’s issue. The bug was around opening links in the locally generated HTML, and not preview as I misinterpreted. We’ve filed a bug report for this, but for now, the workaround is to use Preview, Axure Cloud, or a different browser than Chrome/Edge.