Is there a way to disable shape editing


#1

When i’m trying to edit text on small widgets, I’ll often doubleclick and end up in shape edit mode. Is there a way to disable this “feature”


#2

Yeah, I don’t like this behavior either. You can submit a bug/feature request to support@axure.com for this.

I agree editing the text value of a widget is far more common than editing a shape, so should be higher priority, especially when the text value is non-null (changing existing text vs adding new.) So, if I double-click a widget that contains text, it should by default go to “text edit mode” and not “shape edit mode.” Keep in mind you can always right/alt+Click a widget and select “Edit Text” --which is a nice just-in-case feature.

For me, this usually happens when I have small widgets or are zoomed out. I’ve found that if widget/zoom is large enough, the “shape edit mode” (shape-point cursor shown) only shows up if I click on/near the edge of a widget, not when I click in middle of widget. Regardless, if I start typing, text is added to the widget. in most cases I can single click a widget (or tab) to select it and just start typing to edit text–no double-click required. But, if I want to change just a portion of the text (and not replace it all) it can sometimes be frustrating to get the cursor to show and use mouse or arrow-keys to navigate the string.


#3

Seems like it could also just be a selection mode kind of thing. Node mode.


#4

image

Unless I double-click on the 1 pixel directly in the vertical middle of that, I’m editing the shape like a moron.


#5

Hi @gothate,

Thank you for posting about this. I have reproduced this behavior you are seeing where double-clicking small widgets can result in entering the mode to edit the points of the widget (typically reached via right-click > Transform Shape > Edit Points). Can you please let me know if this is the mode you are referring to?

If so, it also looks like this issue can be avoided by double-clicking the widget near the center instead of double-clicking near the widget’s border. Please let me know if double-clicking in this way seems to help with the widgets you are seeing this issue occur with.

Additionally, I will be happy to submit a feature request to our product team to provide an option to disable entering this mode when double-clicking near a widget’s border.

I hope this helps!

Ashley


#6

There is roughly a 1px space in the exact vertical center of the above widget that allows text editing, something I use very frequently, and quite a margin around and inside the widget that causes it to enter Edit Points mode, which I almost never use.
Frankly you should only be able to enter Edit Points mode via the right click menu, at least for my typical usage. Maybe I’m the only one, but I often have to change text on widgets and almost never have to change a rectangle to a different shape.


#7

Hi @gothate,

Thank you for following up about this. To help, I will include this feedback that you have provided with the feature request submitted on your behalf. This will help our product team better understand your use case so that it may be considered while reviewing and implementing new features.

I hope this helps, and please reach out to us again if you need any further assistance!

Best wishes,
Ashley