Mobile view displaying on desktop but not on mobile devices

Hello,

I have the latest version of Axure 9 and when I generate my prototype with adaptive views, it displays it very small on my phone, when I use the link with just the page name and .html at the end. This was working well before, and I’ve seen solutions here saying the latest update should solve it, but it hasn’t. This is very urgent, is there a known solution?

Many thanks,
Mónica

Hi @monicasara,

This is still filed as a known issue here on our end. That said, does viewing your prototype with the Axure prototype player hidden work in your workflow? This should show the prototype in its respective adaptive view. To do that, click the “X” at the top left of the screen when viewing your prototype’s page.

If you need to view the .html version of the prototype, can you explain how viewing it in this format is used in your overall workflow?

Hi @Justin_Axure,

Thanks for the quick reply. If I don’t use the .html option, the prototype displays correctly, and it always displays correctly no desktop. My problem is really the link displayed as .html on mobile, and this is really important for me, because I built my UX portfolio on Axure and sent it to a company yesterday.

I send the direct link ending on .html but as it’s password-protected it will go to the password screen first. And then it opens the prototype on mobile not at 100% width, everything is the correct mobile view but tiny.

Can you please help?

Many thanks,
Mónica

Hi Mónica,

We’ve added in features to be able to scale your prototype to fit the screen (desktop/tablet/mobile) but you can’t do this if you’re linking directly to the HTML page. You’ll be able to get a URL you can send that will scale properly across devices if you enable the option to “Scale to width”.

Here are steps to do that:

  1. Visit your Axure Cloud hosted prototype.
  2. Click the “Ellipsis” button at the top-right.
  3. Enable “Scale to Width”

Here’s a screenshot of that in the prototype player

If you enable that option, it will modify the URL by adding “&sc=1” to the URL (if you share the URL, it will automatically have “Scale to Width” enabled.

Also, if you don’t want the prototype player bar to show up, you can hide it by clicking the “X” to the left (this will modify the URL as well).

Can you try enabling “Scale to Width” , closing out the prototype player, then entering the new URL into your mobile device?

Thanks!

Hi Justin,

Thank you. That would work if it it didn’t then unformat my desktop sizes. Also, I don’t want to give out the link allowing people to then expand the side bar again, as I’m trying to showcase how Axure can create HTML. Is there any chance you’d fix the direct html linking to also scale to width?

Thanks,
Mónica

As an additional note, more and more companies are now trying to use Sketch instead of Axure, which I’m not happy about. I love Axure’s flexibility with interactions, and defend Axure all I can, and the ability of creating responsive prototypes is a big plus, so I think making .html prototypes display correctly on responsive mobile isn’t likely to be something only I need.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.