Open PDF in inline frame from repeater

I’m trying to load a PDF in an inline frame external to a repeater, from within the repeater. Each item in the repeater has an Item.url, but I can’t seem to target it to my inline frame. I see topics here in the forum in Google which appear to address this, but they are archived when i try to visit them.

My latest effort goes like this:

Set Variable Value speechPDF to [[Item.url]]
Show Speech pdf panel bring to front (a dynamic panel containing the inline frame)

Then, on show, I target the variable url value.

Any ideas?

Hi! If you store the full URL of your target PDF in the repeater, then OnClick of the repeater item you should be able to use “Open Link in Frame” to target your inline frame widget, and open a link to an external URL. In the external URL field, you’d input [[Item.url]] to populate the value of the URL you stored in the repeater, which should open a link to that PDF in the inline frame. Open PDF from Repeater.rp (47.4 KB)

Hopefully that helps!

Thank you, Alyssa. I’ve been trying that approach without success. Just set it up and tried again, but no go. :frowning: Here’s what the rendered html looks like:

And the interactions:


Hi Moretti,

To confirm, is it not working in the local preview or on Axure Cloud? If it’s failing on Axure Cloud, please right-click the page, choose “Inspect” to open the web developer tools, and open the “Console” tab; does that tab show any errors? One thing that comes to mind is that since Axure Cloud is HTTPS-only you may be getting a mixed content error if the link you’re using is trying to use HTTP instead of HTTPS. In Chrome, when you try to load the HTTP link on Axure Cloud it should show in the browser that it blocked the insecure content, but you can choose to show it anyway:

Another way to get the HTTP content to load would be to publish the project to a shared workspace and turn off SSL for that workspace on classic Axure Share; note that this feature is deprecated in the new Axure Cloud and can only be toggled via the classic Axure Share site, but should help for now:

Hopefully that helps!

Thanks, Alyssa. I’m only previewing this locally and am trying this in another .rp file with the same result that the pdf won’t render. I’m behind a government firewall, although the links (https) are from our public website. No errors in the console. I will try this again at home.


Hmmm, do you get errors in the browser console when the PDF fails to render in preview? If you find that it still won’t render for you even when you’re not behind the firewall then would you mind posting the file (or a redacted version of the file with just the affected widgets) here or sending it over to so that we can dig in and advise?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.