Show-hide inconsistency

Hi there,

New to Axure and having a few issues with a mobile prototype I’m working on.

  1. What I’m trying to do is have Help text Show and Slide Up from the bottom on Got Focus on certain fields and Slide down on Lost Focus. Seems simple but the Password field is only working properly and Hiding the Help text when nothing is entered in the field. If I type in it and lose focus it doesn’t go away. Seem unnecessary but I tried adding a Case that Hides it when the field is Valid but that doesn’t do the trick either.

  2. My next issue is that I want that Help text to be sticky and pinned to the bottom. I’ve created a dynamic panel and pinned it and that’s working fine. That panel is hidden most of the time and I have it placed under everything else in my layers, however, it seems to be blocking interactions with fields in that area. I’ve now set it up to Hide on Click (even though it’s already hidden) and if you click twice you can click into the field. But that’s obviously not how we want it to work in the prototype. I’m not sure why a hidden panel that behind everything else is blocking an interaction. But if there’s no way around that is there a way to fake a double click that the user only clicks once?

  3. Once I’m able to get around the above issue and click into the Security answer field, that field is acting especially finicky. It was showing the Help text on focus. Now it’s not. Also It seems to only recognize losing focus if I click above it and just generally not sticking to any consistent behavior.

I’m sharing a file I’ve been playing around with to troubleshoot. There are three pages with slightly different tests/interactions set up. Would greatly appreciate any help/advice!

Thanks.

Did you forget to share the file? :slight_smile:

1 Like

This has been resolved. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.