Unable to connect to shared project


#1

I'm unable to connect to shared projects across our corporate network. Have direct connections confirmed but Axure unable to identify. Can "Get and Open Shared Project" initially, but then unable to Check In any new files within project, nor can I "Get All Changes from Shared Directory", etc. Each time I get "Unable to connect" Alert.


#2

I am having the same problem. For me it happens when I am trying to access a project share created on a Mac (I'm on a PC). I can get the shared project initially, but trying to get updates gives me the error: "Unable to connect to: file://servername/directory/sub-directory/filename If you are not working offline, please try again."

What I notice is that the path is a mac path, since it uses "/". PC file paths use "\". When I setup the project, I put in the file path as a valid PC file path, but for some reason it seems to be using the mac file path for updates. I can't find a way to force it to use the PC filepath. Any suggestions?


#3

I'm having the same problem. Both people trying to access it are on PC. I created the project and can check files in or out. The other user cannot. She gets an 'Unable to Connect' error. She was able to get the project, but immediately couldn't check files out.

Has anyone resolved this issue?


#4

Hi Yossarian,

Is your colleague getting the Error Report dialog? If she is, have her enter her email address into the email field and note this forum thread in the "more information" section, then send the report along. This'll give us more info about what might be going on.

I'd also like to know more about the setup you're using to store the Shared Project directory. Are you storing the Shared Project files on an SVN server, using an SVN service, storing on a shared drive, or using dropbox (or something else)? Any information you can provide will be helpful. Thanks!

Ben


#5

I have the same issue using windows. I created the project and can check files in or out in the first time. but when I close the project and open again, it doesn't work. Anyone can help on this ?



#6

Have fixed the issue. because Axure can't support the Chinese Character in the directory name.


#7

Hi,

We're having trouble using the 'Team' function. I created a team project in my desktop and share the folder in LAN. And I'm able to check-out/check-in pages in my personal computer.

But my colleague is able to get and open team project at first, but after this she is unable to check-out/check-in any page. The detail error alert shows in below snapshot:


Any help would be greatly appreciated.

PS: We're using Axure 7.0 in Windows 7 and Windows 8.

Thanks.

Reson.


#8

Hi Reson,

Thanks for updating with this information. If your colleague isn't able to access the files hosted on your computer, it sounds like there's a permissions setting preventing her from connecting correctly. Can you please verify that she has full read/write/execute permissions on the directory that's housing your team project?

Regards,
Jonathan


#9

Thanks Jonathan for your quick response.
I'm not sure what's the permission issue, I've share the folder to 'Everyone'. Also my colleague can access the project and load the pages into the local disk in the first time. but can't check-out or check-in. pls help analysis this. thanks.
By the way, we've already set up a SVN server and build the Axure project in SVN server. Till now , it works well.

Thanks.
Reson.


#10

Hi Reson,

To clarify, is that directory on your hard drive acting as an SVN repository? Or is it that you simply have an SVN server set up on your computer? If you are running through an SVN server, please ensure that it's a plain vanilla installation with absolutely no hooks or other customizations, and that your permissions are correctly configured there as well.

Have you had your colleague try getting a new local copy of the team project? This can be done with "Team > Get and Open Team Project". If your colleague needs to preserve any changes that have been made, you can follow the more extensive directions listed here:

Team Projects Troubleshooting | Axure

Please give that a shot, along with verifying that all permissions are correctly set, to see if anything changes.

Regards,
Jonathan


#11

Thanks Jonathan.
The issue occurs only when we use the share folder to build the team project.
when we changed to SVN solution, there's no issue.
Thanks.

Reson.


#12

Hi Reson,

I'm sorry for the slow response. It sounds like things are working fine when you use the SVN server--is that right? Are you able to move forward with that solution?

I'll be standing by!


#13

Hi,
I have a similar problem. I can’t create a project on our company’s SVN server in the first place.

My Setup

  • Axure 7.0.0.3189 on Windows 8.1 Enterprise
  • SVN hosted by IT
  • read/write/delete rights in a (sub-) directory of the SVN
  • access via web browser and Tortoise SVN works fine
  • cached SVN authentication deleted (Team Projects Troubleshooting | Axure)

Steps to repeat:

  • File > New Team Project
  • enter name
  • enter SVN path to newly created directory (SVN path starts with https:// - in case that’s relevant. Also no spaces.)
  • Next
  • Alert: Unable to connect to: <SVN path>. If you are not working offline, please try again.

I read this thread and I tried all from the trouble shooting list.
The only open item is: I can’t really say if Jonathan’s requirement of “If you are running through an SVN server, please ensure that it’s a plain vanilla installation with absolutely no hooks or other customizations, …” is fulfilled. If I guess, I’d say, no. If you can tell my what exactly might be the problem, I can ask and find out. But I probably can’t change it.

(In the meantime we tried out creating projects on a shared network folder. That works fine. But we’d prefer the SVN solution to be able to recover the data in case someone accidentally deletes everything.)

Thanks.


#14

Hi maria k.,

Thanks for those details! I have some additional troubleshooting steps I’d like you to try:

  1. As a first step, try using “http” rather than “https” in the project URL. We’ve received reports where changing to the “http” protocol solved the problem (mainly for Mac users), and this may be a similar case.

  2. You mentioned that you cleared the cached SVN authentication. But just in case–let’s double-check to make sure that’s not the problem. To clear your cached authentication, delete the contents of the “auth” folder. The next time you try to connect to the SVN server from Axure RP, you should be prompted to enter your authentication.

  3. Could you verify that the directory you’re entering exists on the SVN server? The directory you enter at the team project directory step must already exist on the server. Axure RP will then add a directory beneath that one with the project name. For example, if you specify “svn://svnserver/OurProjects”, the “Our Projects” folder should already exist on the server.

  4. Since your team project is on an SVN server, verify that you have full access to the repository.

  5. Lastly, you mentioned there’s no spaces in the team project directory. However, if there are any other special characters (e.g. &, *, etc.), try removing those as well.

Hopefully the above helps. If those don’t work, it may be helpful to loop in your IT team at that point since they’re the ones who know how the SVN server was configured.


#15

Hello Jane,

OK, I tried out your suggestions. Thanks. Unfortunately it didn’t help.

  1. I removed the “s” in https => didn’t help.

  2. The auth folder contained 4 subfolders. I removed them. When trying to create the project 3 of the 4 folder appeared in the SVN again. But Axure still could not connect. And I was not prompted to enter a password.

  3. Yes, it does. I created it, copied and pasted the path. Didn’t help.

  4. Yes, I have. Just to be 200% sure, I even deleted the folder and re-created it again.

  5. The only non-letter characters are a dash (-) and some dots in the svn repository name.
    My whole path is: https://rnd-svn.companyname.de/engineering/trunk/Productname/AxureTest (slightly modified wording, but apart from that unchanged).

If I try to loop in my IT, how should I best approach this? All I can tell them that I can connect to the SVN with my Tortoise client and Axure can’t - but they probably have no access to Axure log files or something which could tell them what the problem is. What about my question from the previous post:
“The only open item is: I can’t really say if Jonathan’s requirement of “If you are running through an SVN server, please ensure that it’s a plain vanilla installation with absolutely no hooks or other customizations, …” is fulfilled. If I guess, I’d say, no. If you can tell my what exactly might be the problem, I can ask and find out. But I probably can’t change it.”


#16

Hi maria k.,

Ah, darn. I’m sorry to hear none of those worked. Since you mentioned that your svn repository name contains a dash and some periods, could you try creating one without any non-alphabetic characters? Special characters have been culprits in the past for team project errors, and I want to make sure that this is not the case.

In regards to your question about the vanilla configuration, the best thing to ask your IT team is if the SVN server using to store the team project has any special scripts or settings in place. This is because we’ve seen that custom scripts and other additions tend to interfere with the functionality of team projects.

Hopefully your IT team can help to narrow down on what’s causing the connection to fail. If you’d like more direct one-on-one assistance, feel free to email support@axure.com (with this forum thread in the email body) so that we can further diagnose the problem.


#17

Hi, I am facing a similar problem. Our shared project is hosted on a network folder. I am able to check-out but when I try to check-in, it gives me a message that : Access is denied, although I do have access. Could you please help.


#18

Hi vk_axure,

If you haven’t already, could you try the troubleshooting steps at the link below?

Troubleshooting Team Projects (SVN Method)

What OS and version of Axure RP are you using, and are you able to create a test team project at the same network location that the team project is hosted on? From your description it sounds like you have permission to read files but not write or modify them, so I’m wondering whether creating a test team project at the same location will also fail.

If you could submit the error dialogs and include a link to your forum post in the message body then that will allow us to check the error stack on our end. If this issue is urgent, please email us directly at support@axure.com so that we can work with you one-on-one. Thank you!


#19

Hi,I had a similar problem.When I used axure8 on Windows 10 , it’s good.But I open axure8 on my MacBook Pro,Team > Get and Open Team Project,and enter the svn path,
Alert: Unable to connect to: . If you are not working offline, please try again.


Then I searched this problem.Now,I found a way.Change the svn path “server” to an IP address.Like this