Advise for Windows 10 Performance Issues


#1

Hi,

I started experiencing performance problems with Axure 9 on my Windows 10 based machine recently:
About every 20-30 seconds the program hangs out for a while (freezes, can’t type or move mouse), even with a plain new file after a fresh installation and while doing very basic operations: create box, type in text, drag, scroll, etc.
It will even freeze when I’m typing a new name, while in the Save dialog, if I stay there too much.

I started using v9 somewhere in Q4 2019 and I’m positive it used to work fine even with complex files.
I do not have the same problems with Axure 8 - I have both version installed.

I downloaded and tried with version Axure RP 9.0.0.3655 from July 16, 2019, but with the same effect so I concluded it is a problem on my side.

Any advise how to troubleshoot this to discover what is causing the problem?
Is there a cache or potential corrupted application files I need to delete manually when uninstalling?
Can I monitor Axure performance somehow to discover what is happening every other 20 seconds to makes it hang out?

As a hardware I’m using a Razer Blade 2016 (GTX 1060) laptop with the most recent updates for Window 10 Home Edition. I did not made any other software changes, but Windows update, Axure updates and display drivers updates.

Some of the things I tried without success:

  • Use a new empty file for testing
  • Switch to older version from January 2020
  • Switch to older version from July 2019
  • Unistrall/reinstall latest version
  • Sing out from Cloud
  • Uninstall Razer Cortex optimization software
  • Unplug my external monitor and use the application only with my Laptop
  • Change graphic adapters
  • Update NVidia display drivers
  • Switch all graphics settings from quality to performance
  • Change power optimization settings to maximum performance
  • Use different color profile (Adobe RGB, Apple RGB, etc.)

Any other potential actions I could take to try and fix this?

Thanks,
Ivan


#2

Send all this info in an email to support@axure.com They are probably in best position to help you.

You might get input here from other users who might have experienced similar issues, but that will be hit-and-miss and may not address the root problem. I use RP9 on Win10 and have not seen this issue.


#3

OK, Thanks. I might do this tomorrow.

In fact I kept digging into this issue, because it was blocking me from doing my work properly and after removing the folder /AppData/Local/Axure, now it looks the app is working back as normal with and just some basic settings gone.

Not sure, if there is some critical info in there, for me to keep the backup I made - at a glance looks like just settings, backup files and logs, which I’m OK to lose permanently.