Axure 9 3665 Build is super sluggish on MacOS Catalina


#1

MacOS 10.15, Axure 9 (3665) scrolling, zooming, moving within document is slow, i’m not using any libraries. Also when you first launch Axure in Catalina, it says, this app is not safe, seems like it’s needed to be notarized by apple. I think for the price you ask for this soft, it’s not acceptable, that it’s still in unusable condition on MacOS.

On my external display 4k scaled to 1080p, it seems to work ok, but on my built-in MBP 15" 2019 display it’s horrible, also it’s not related to a specific project/file, because i’m using a blank new document.


#2

Same stuff here. iMac 5k, 2017…


#3

Hi! The issue with the OS popup preventing Axure RP from launching right away after upgrading to 10.15 is being looked into on our end. To get around it (for those still running into the issue) you can go to “System Preferences > Security & Privacy > General” and click “Open Anyway” next to Axure RP.

For the lag that you’re seeing in new files on 10.15, do there have to be certain types of widgets on the page to reproduce the issue (for example, images)? Or do you have the Axure RP window open at a very large windowed size (e.g. taking up most of the monitor space but not set to full screen mode)? This would help to verify what sort of scenario the lag is occurring in so that we can investigate.


#4

Hi @Alyssa_Axure,

Here is a screencast of the issue - https://youtu.be/WCcCFU-yENk.

Let me know if I can help with anything else.

Thanks!
SK


#5

Thanks for the video @kckfm! That was very helpful for us. :slight_smile: There’s a known issue that we’re looking into on our end where Macs with very high resolution monitors cause Axure RP to perform more slowly (even with small files), specifically if the resolution settings are higher and if the Axure RP window size is large and not in full screen mode. If you both wouldn’t mind, could you post screenshots of your current display settings for your monitors so that we can verify your settings? You should be able to see those in “System Preferences > Displays”.

As far as current workarounds, one method would be to turn down the resolution on your monitor to see if that helps. Alternatively, we’ve also had some users report that clicking the green button in the application titlebar to go full screen (instead of double-clicking the header to maximize the window) also helps to prevent some of the lag, if you haven’t tried that already.

Thank you! :slight_smile:


#6

Hi @Alyssa_Axure

I use the full 5k resolution. I have 2 monitors. The second one is EIZO ColorEdge CG223W (low res monitor - no lag there).

Thanks!
SK


#7

Excellent, thank you for those! I’ll add those spec to the ticket we have filed. Meanwhile hopefully one of the workarounds works for you; using the green “+” button in the Axure RP title bar to go full screen should help to reduce lag a bit without you having to change your resolution on the 5k monitor.


#8

@Alyssa_Axure, making it full screen, using the green + icon does not make it better. Waiting for a fix, thanks!


#9

@Alyssa_Axure i have standard Macbook Pro 15" 2019 retina display which is 2880x1800 i use it in scaled mode 1440x900, windowed mode. Also green plus sign did nothing for me either.


#10

No sense for me to scale down resolution… @Alyssa_Axure please make sure this fix comes very soon.
Thanks!


#11

+1
Experiencing the same sluggishness since upgrading to Catalina. When zooming and scrolling, Axure becomes choppy and frequently hangs. The sluggishness seems to grow worse the more zoomed in the project gets.

Running Axure 9.0.0.3669 on a Macbook Pro running MacOS 10.15
Using a two monitor setup with resolutions of 1680x1050 and 2560x1440. The choppiness is problematic when running Axure on either monitor.