Axure local Preview not loading

Hi,
I am trying to local preview my project.
The preview loads the name of the pages on the left, but the screens are blank.
When I share it on Axshare it looks fine.
Did anyone encounter such a thing?

Hi Ozshmo,

So it sounds like the pages in your file are marked for generation in preview (“Publish > Preview Options”) but don’t render regardless of whether previewed directly or clicked via the preview sitemap. To confirm is this issue happening in just one specific browser, or all browsers on your machine? If all browsers have the same behavior for preview but generating local HTML and publishing to the cloud works fine, then it seems something is interfering specifically with preview. To confirm in that case, can you verify that 127.0.0.1 and localhost are not blocked by any proxy or firewall settings on your machine? If you happen to have an antivirus program installed (especially Kaspersky), another thing you can try is to temporarily disabled the antivirus and then try previewing; if it works with the antivirus disabled, then you’ll want to check in the settings of that tool whether anything is configured to potentially block Axure RP, access to localhost/127.0.0.1, or specific ports.

If the issue’s urgent feel free to forward it with a link to this forum thread to support@axure.com so that we can dig more!

Hi Alyssa,
You are right!
It was the antivirus, I am using Kaspersky and when I turned it off it generated just fine.
I checked the restrictions and Axure is not restricted. So I don’t know why it is not working still.
But I guess i need to take it up with Kaspersky support.
Thank you

I’m glad that helped to narrow it down to Kaspersky causing the interference! If it helps, on your end you can try going into Kaspersky and navigating to “Settings > General Settings > Exclusions” and double checking both that Axure RP is added as a trusted application, and that in the “Monitored Ports” section the preview port is unblocked:

https://support.kaspersky.com/14832#block3

That should do the trick, along with double checking that HTML, CSS, and Javascript are allowed to run locally. I hope that helps!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.