[Bug] Adaptive Master Elements Won't Stay Aligned

bug-report

#1

Long-time Axure user, first-time forum poster. This bug with adaptive masters has frustrated me to the point of creating a forum account just so I can get this addressed. Here’s what’s happening:

I create a master with 5 adaptive views. I place elements into the base view and painstakingly align them to where I want. I arrange the elements in the other views and then place the master on the desired page. I continue working on the page, adding panels and masters where necessary. I scroll back up to see how everything looks, only to find one or two of the elements in the first master have completely shifted around. The more masters and panels I add to the page, the more these elements appear to shift.

This forces me to go back to the master I’ve already finished and reposition the elements over and over again. The whole point of a master is to place the elements once and be done with it. I am constantly having to reposition the elements on the master and I don’t know how to make it stop.

Here’s a screenshot of the kind of movement I’m seeing (obviously when I placed the prices on these masters, I didn’t intentionally hang it off the edge of the container):

One of the ways I’ve been able to replicate this behavior is:

  • I add and position some elements on a page and create Master A from those elements.
  • I add Elements 1, 2, and 3 to the page.
  • I select Master A and Elements 1, 2 and 3 and create Master B.
  • Objects in Master A have now become misaligned.

Is anyone else experiencing this? Is it a known issue? Are the devs aware of it? Please help.


#2

Hi Karl!

Thanks so much for reaching out about this! Hmmm, I’ve tested out some similar steps on my end with some masters and widgets, but I haven’t been able to reproduce this behavior just yet. Would it be possible to take a look at your project file to further investigate this issue? If you would like to keep your project file confidential, feel free to email support@axure.com with your project file and a link to this forum thread for reference. Thank you! :slight_smile:


#3

Hi all!

KarlVickers submitted their file via our main support channel and the issue with the widgets shifting positions boiled down to a bug in Axure RP 9. Essentially, if you have applied a widget style to widgets that are used across multiple adaptive masters and you locally override one of the style properties of some of those widgets, then converting the master to a dynamic panel causes an odd position shift in the widgets that that had their style overridden. Our QA team has this filed for further investigation. If anyone else has seen similar behavior then hopefully that helps to pinpoint and confirm the behavior in your file! :slight_smile: