[Bug] Flyout does not work by hosting, only by local preview

bug-report

#1

Hi, at my prototype:

https://9ac2to.axshare.com/#id=miqoja&p=fahrzeugauswahl_via_datenbank

the flyouts does not work by hosting on Axshare, only by local preview, where it works fine. Is this a bug?

Best,
Max


#2

Could you also upload your .rp source file? Looks like the flyouts in your link work for me (Win10 + Chrome). Some of them may not fully show correctly, and there could be many reasons for that. Likely easily fixed if I can see your .rp file.


#3

Interesting, that it works on windows, on the mac it does not work on chrome and safari.
Not working means that I can click on the flyout, the flyout appears, but if I then hover into the area (list) which appeared, the flyout disappears without the possibility to click on an entry.
RP-File is enclosed.
Thanks for your answers!Untitled.rp (347.1 KB)


#4

Aha. Thanks for the clarification. No, in your link to Axure Cloud prototype, I’m not able to click on any of the dropdown menus which are displayed when clicking any of the buttons. The menu is shown but as soon as I move cursor over the menu (and off of the button) the menu disappears. Like for you, this occurs when prototype is published to Axure Cloud, and also when HTML is generated locally, but not when Previewed from the editor.

I did try this on my phone as well (iOS 1.32 + Safari) and the menus were clickable: touching on any item in the dropdown menu closed that menu and updated text on the button. (Not surprising as there is no hover event to trigger the flyout menu to close.)

I removed the adaptive views from your prototype and the flyout menus behave correctly in HTML and Axure Cloud. I Added an adaptive view again and they fail. So, this does look like a bug associated with adaptive views and the Show widget with “Treat as Flyout” option. I encourage you to submit this as a bug to support@axure.com .

I tried a few things to work around this issue, and came up with this method: Show the drop menu panels normally, without the “Treat as Flyout” option, but with “Bring to Front” option. Then, on the parent group (containing button and menu) use the Mouse Exit event to hide the dropmenu. This should have the same effect as the flyout. A little more coding, but it does work until this flyout issue is addressed. By the way, you can save some coding by placing your “Show” action on the button group (containing the button rectangle and arrow widgets) instead of on both the rectangle and arrow.

Here is my .rp file and demo on Axure Share:
flyout-menus.rp (503.6 KB)

https://yjxf4m.axshare.com


#5

Hi mbc66,

thanks a lot for testing, discovering the problem and the workarounds! Helped me a lot!

Have a very nice day!
Best,
max.


#6

Hi all, just wanted to follow up here that we were able to pinpoint the bug via email; looks like if you show a dynamic panel that is set as “Fit to Content” as a flyout on a page that has adaptive views enabled then the flyout won’t stay open in the published Cloud URL; removing the adaptive view or turning off “Fit to Content” helps to work around the issue for now. We have this bug filed on our end with QA, but hopefully that information helps if anyone else has been running into similar behavior!


#7

Hi Alyssa,

thanks for your follow up and the workaround. Fit to Content is a good powerful feature, which we use all the day, everywhere. Would be very sad to loose this. So it would be nice if you could follow up again, when the technical team could resolve the bug.

Thanks a lot,
Max


#8

Hi Alyssa, I have an additional issue and don’t know whether it is the same bug or another one. I recognized that in the function code of some buttons, where on klick we put the text of a button into a flyout-menue-button, there is an additional space-letter. This may come from converting from ax 8 to 9. The strange thing is, with this additional space we get an error-message in the button where the text of the other should appear. But when I delete the space the functionality does not work at all (no text appears on the target button, but also no error message). Please see the enclosed images.

https://9ac2to.axshare.com/#id=xtpr5j&p=test_2&c=1

What do you think?


#9

Ok, I figured out that the code [[This]] is wrong and has to be [[This.text]]. But beside this, with the space before the code, this is something that is still wrong, or?


#10

Hi! Good catch! That’s correct–if you’re trying to set text on another widget to match the text of the current widget that is triggering the action, then you’ll want to use [[This.text]] rather than [[This]]. If I’m not mistaken, [[This]] means “the whole widget” instead of “just this widget’s text”, and presumably the space breaks this further. [[This.text]] should do what you want, either that or using a local variable to target your widget’s text should work!