[Bug] When editing text, mouse cursor becomes super sluggish

To repeat:

  1. Add any widget to the canvas
  2. Double click or press F2 to start editing the text in the widget
  3. Move the mouse around the widget. It becomes sluggish and jerky.

Using Mac. This does not happen in Axure 8. Extremely frustrating.

Hi,

To confirm, what build of Axure RP 9 are you currently using? You can verify this via “Help > About Axure RP”. If you’re not currently on the latest stable build (3669) or release candidate build (3673) then can you verify whether you still experience this issue after updating? You can update via “Help > Check for Updates”.

If it persists, then what version of macOS are you running, and does this issue happen on a retina monitor or otherwise high resolution monitor? Is it specific to moving the cursor around a widget on which text is being edited, or do you generally see that moving widgets on the canvas is slow?

Axure 3669
MacOS 10.14.6 Mojave
It feels much worse on a Thunderbolt display than on the MBP built-in Retina
Happens only over the actual text with the focus, not even the entire widget. Mouse cursor is switching quickly between caret and arrow.

Thanks for that! This issue sounded very familiar, and it looks like so far we’ve had just one other report of the same behavior that you described, and we were able to reproduce part of the issue but not all of it. We’re able to reproduce the issue where the mouse cursor rapidly switches back and forth between the regular cursor and the text edit cursor when the cursor is over a text edit zone on a widget, and the issue seems to be aggravated on lower resolution monitors especially when the mouse cursor is set at a larger size via System Preferences > Accessibility > Display. The part that we haven’t been able to reproduce so far has been the slowness that occurs along with the flickering cursor. To help narrow down the issue in full, would you mind letting us know what resolution your Thunderbolt display uses and whether changing resolutions affects it? In the meantime I’ve gone ahead and added this issue to the filed ticket to help add more information for QA.

Changed the mouse cursor size to Normal (was set to be just a bit bigger) and the issue disappeared! Thanks.

Thunderbolt display has 2560x1440 resolution.
Lowering the resolution to 1280x720 didn’t help.
Sometimes it slows down without flickering, so maybe they are not related.

Excellent, I’m glad that helped! I’ll update the filed ticket to note that the smaller cursor size seemingly stops issue, at least the lag. Thanks for confirming! :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.