Fully working form in Axure

Hi there!

Is it possible to make a fully working (prototype)webform with a real send-to-email address functionality and an auto reply message to the sender?

I want to demonstrate how the user is filling in the web form and than the total flow progress when the form is being send to an actual email address. so I can show what the Admin will receive and how the data is being progressed.

Do I need to work with Plugins based on php codes or are there any other possibilities to make this form work?

I hope you guys can help me out.

Cheers,
Eugene

The closest you can do in Axure alone is use variable to build a mailto: link, like so:

mailto:someaddress@email.com?subject=[[AxureSubjectVariable]]&body=[[AxureBodyVariable]]

But all that will do is open the user’s default mail client with those values prefilled. If you want to mail an HTML email from a server, well you’ll need some sort of mail service you’re using. You could make a GET request from Axure with a link and have your server process the request and send the mail, but that’s well beyond the scope of Axure and totally up to you.

If this were my project, I’d just make a mockup of what the email would look like and include that separately.

2 Likes

Hi nkrisc —

Saw your post and was attempting to set up a simple mailto: inside an Axure RP 8 prototype. That is a subject with a body.

However, I just can’t seem to figure out how to pass an Axure Variable (e.g. LVAR1). For example, all I get for the Subject in the e-mail is LVAR1 (e.g. subject=[[LVAR1]]).

Can you point me in any direction of examples?

Thanks,
Fig

hey Fig,

Here’s a sample:
mailTo Link.rp (50.1 KB)

Here’s screenshot of the logic:

1 Like

Hi UXPT —

Many thanks. I was making it WAY too complicated with dynamic panels and such.

KISS reigns again!

Regards,
Fig

UXPT —

One more quick query from a non-programer…

I’ve determined that I can actually add several text fields to the “body” of the email. However, what would the code be between [[Body1]] and [[Body2]] to insert a couple of carriage returns?

Thanks,
Fig

Arg! I’m just not getting it. I’ve tried all sorts of ‘code’ (e.g. et al).

Here’s the line I’ve been working with…

mailto:hello@address.com?subject=[[subject]]&body=[[BigBody]]\r[[add]]

What am I doing wrong?

%0D%0A as noted in the link I sent you worked for me. It’s opening in outlook for me.

mailTo Link.rp (51.0 KB)

1 Like

UXPT —

Thanks : )

I finally get it!