Necropost: animated gif not working. Again

I know that this topic has come up multiple times, but for the life of me I can’t get an animated gif to work in my prototype.

Here’s the gif I’m using

Loading_icon_cropped

Which I got from here: https://commons.wikimedia.org/wiki/File:Loading_icon_cropped.gif

As you can see. It gifs. But when I generate my prototype it just doesn’t.

  • I’ve tired drag and drop
  • I’ve tried importing via the image widget
  • I’ve tried copy paste
  • I’ve tried other gifs to see if it’s just this one

Nothing works. Is it just me?

I’m on Mac Mojave 10.14.6 (18G95) using 8.1.0.3388 if that helps.

Hi JonB!

Sorry to hear you’re running into this issue! Hmm, I’ve tested out using this gif in a new project on my end and previewed it in Chrome, Safari, and Firefox. So far it looks like the gif is animating as expected. I’ve attached my sample file–please let me know if the gif runs on your end!

sample-gif.rp (60.7 KB)

Yeah, works for me on Windows, latest Chrome browser, latest RP8.

Stupid things you shouldn’t have to do, but often fix problems like this…

  • Restart Axure, restart browser
  • Reboot computer
  • Clear browser cache

Make sure you’re not allowing Axure to ‘optimise’ the GIF when you import it. That breaks the animation. I don’t really understand the image optimisation function, as it generally destroys the quality of any image I import and breaks animated GIFs.

Thanks all for this, but I’m forced to conclude there’s some weird bug going down.

Chelsea’s file worked for me. So I created a brand new file, and imported the gif into that. It worked.

However, it seems that when I import the gif into the Axure file I’m working with, it doesn’t. Here’s a page from that file (contains various rubbish but the gif is at the top. non-gif.rp (92.0 KB)

Does that work for you? It doesn’t for me. But why?

Yes, that’s a very odd bug. I loaded your file and the spinner gif didn’t work. I dropped in a couple of other GIFs and they didn’t work either.

The exact same GIFs dropped into one of my working files worked fine. I used drag and drop method consistently. Probably worth Axure support taking a look at your file, and you may need to copy your work to another new file.

Hi JonB!

I just took a look at this file–it looks like removing that border around the GIF image allows it to animate as expected. There’s some border width styling applied to your project’s “Default” widget style, and that’s applying a border to all new widgets placed on the page, which explains why new GIF images added to the file weren’t able to animate as well. I was also able to reproduce this issue when adding a border to my sample file’s GIF.

This appears to be unexpected, so I’ll be filing a bug report regarding this behavior with our respective teams on your behalf. Thanks everyone! :slight_smile:

1 Like

Ah OK - that explains it! I inherited the file from somebody else who must have (inadvertently?) applied some border width styling default.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.