Pasting into Repeaters from Excel - Now It Works, Now It Doesn't

repeater-widget

#1

I use a lot of repeaters in my prototypes. I maintain the fairly intricate sample data in a series of Excel spreadsheets.

And while I know this was a known bug in the beta, it was apparently fixed, because I built my current version of the prototype using CtrlC in Excel and CtrlV in the repeater. No problems. Freaking brilliant .

Now, it doesn’t work. I get an “Image” in a cell when I try to paste, either via CtrlV or Edit/Paste.

This is happening, by the way, as I’m working to convince the people at HQ that Axure is a much better tool for prototyping than (ptui) Figma - so aside from the frustration it’s causing me, it’s not helping my case much, either.

Is there something that can be done about this - like, fast?

I’m on v9.0.0.3706.


#2

For fastest reply from Axure, send an email to support@axure.com and include an example .rp file. Worth doing while you’re crossing your fingers and waiting for a fellow forum user to post a solution. I’ve found them to be very responsive and helpful.

…I wish I had one for you. Pasting from Excel has been working for me, but I’ve had issues when pasting data from other Office apps like OneNote, where text gets pasted as image–but this is not unique to pasting into Axure repeater. Pasting into another app like Notepad++ then copy-pasting from there tends to help. I suppose there is a small chance it has to do with your clipboard settings and/or Excel settings.

The latest RP9 version is now 9.0.0.3707 …and the release history mentions fix for pasting image into repeater database (not Excel data, but they changed something with pasting…) You can also download previous versions to see if that addresses your problem in the meantime.

https://www.axure.com/release-history


#3

Have you tried maintaining your data in a Google spreadsheet? I haven’t installed the Axure build with the issue in question so I don’t know whether this would fix this problem, but it might be worth a try. I used to use Excel the way you do, but pasting from Excel always inserted a blank row after my last item, whereas pasting from Google sheets doesn’t, so I switched.

Jeff


#4

I am having this same problem. Copy/pasting from Excel used to work, now it doesn’t. Just pastes an image in.