Roboto Light gets substituted to Roboto Thin

Axure changed all my prototypes’ ‘Rotobo Light’ fonts to ‘Roboto Thin’ and I had to reassign the ‘Roboto Light’ to all my text manually. I also have a case where: even if I changed the font from ‘Roboto Thin’ to ‘Roboto Light’, when I published to the cloud it reverted the font to ‘Roboto Thin’… Any idea?

Same issue, it would be nice if someone would look into it.

After you (Axure) purged the forums of all community content, the one upside was a fast response rate to tickets. Is that no longer the case?

Hi @jfboisvert and @gothate,

Thank you for posting about this. If you are still seeing this problem where Roboto Light appears as Roboto Thin in Axure RP, can you please try following these steps?

  1. Can you please confirm that you are running the latest version of Axure RP 9 (9.0.0.3723)? If not, please try updating via Help > Check for Updates in Axure RP.

If you are seeing this occur in the latest version, this problem could be occurring on your machine due to your specific configuration, such as if the font files or Axure RP’s program files have somehow gotten into a bad state. To troubleshoot this, can you please try the following?

  1. Please try un-installing the fonts from your machine and re-install them via this link from Google Fonts:
    https://fonts.google.com/download?family=Roboto

  2. Please try clearing Axure RP’s cache and temporary files by quitting Axure RP, and then removing the content in these folders, per your machine type.

For Mac, open the Mac Finder, select Go > Go To Folder, submit the following path, and remove the contents of the Axure-9-0 folder.
~/Library/Application Support/Axure/Axure-9-0

For Windows, open the Windows File Explorer, highlight all text in the address bar, submit the following path, and remove the contents of the Axure-9-0 folder.
C:\Users%USERNAME%\AppData\Local\Axure\Axure-9-0

  1. If the previous steps haven’t helped, and if the font is only appearing as Roboto Thin on preview/publish, I would also recommend checking the Font Mappings settings in your project to ensure that you are not mapping the Roboto Light font to Roboto Thin. Here is a link to more info on this:
    https://docs.axure.com/axure-rp/reference/web-fonts-font-mapping/#font-mapping

  2. If none of these steps has corrected the problem, can you please write in to us at support@axure.com, and reference this forum post so that we may troubleshoot this problem further?

Thank you!
Ashley

1 Like

Okay, clearing the cache and reinstalling the font seems to have sort of worked.

Originally, Mac Font Book and Axure RP 8 were only displaying 3 variations of Roboto (Light, Regular, & Bold) while Axure 9 however was displaying all 12 variations of the font.

Clearing the cache and removing and reinstalling the font now shows the full listing in both Axure 8 and Font Book. I can only imagine when I was creating stuff with Axure 8, it must have been actually setting stuff as “Thin” but displaying Light in the dropdown and working areas. Not sure if is due to some sort of corruption, or a mac font issue, or an old font having variations added later (but still not updating in Font Book?)

My old prototypes still have the wrong fonts but I think I can fix things going forward at least.

1 Like

I am running 9.0.0.3723 and yes. These were prototypes originally created in Axure 8. The problem was/is in both my main prototypes created during that time. Axure 9 has issues between Roboto Thin and Light. It substituted all Roboto ‘Light’ to ‘Thin’. I am refactoring manually but sometimes changing the font does not take. On ‘Preview’ I see the change back to ‘Light’ from ‘Thin’ and on ‘Publish’ I still see Roboto ‘Thin’. Only a font change and then back to Roboto ‘Light’ seems to work but not always…

Hey jfboisvert, what Roboto font options does your Axure 8 have? Or is that not installed anymore?

@gothate Axure 8 is not installed anymore.