White rectangle appears on the preview

Hey there, I’m a newbie prototyping for the first time. I have Axure 9 beta. I’ve made some pages with the Adaptive View enabled, with three sizes: mobile portrait, tablet protrait, and a custom desktop size at 960px wide. All looks fine and smooth when resizing.

The problem: when I preview the larger view, a vertical white rectangle appears at the top left. There’s absolutely nothing in there in the page editor. I’ve gone through all the masters and views and there’s nothing!

I’ve been all afternoon looking for the answer to my problem in this forum and in the whole internet but with no luck. It’s bugging me a lot. Also I’ve tried to preview it in Opera and Chrome, but the rectangle magically appears there as well. The screenshot shows the problem.

Can somebody help me please?

Hi Helionking,

Sorry to hear that you’re having difficulties with your adaptive views! Just to confirm, it sounds like two of your three adaptive views are previewing correctly, but your custom desktop view is showing a rectangle near the top left of the screen when previewed. Is this correct?

While you were reviewing your project, did you find a similar rectangle widget placed on any other views in your project? Additionally, could you please let me know if this file was converted from an Axure RP 8 file, or if this file was originally created in Axure RP 9? If this was created in Axure RP 8, taking a look at the Axure RP 8 file as well as the Axure RP 9 file may help to troubleshoot the issue. If the file was originally created in Axure RP 8, please send along the Axure RP 8 and Axure RP 9 files for this project. If this file was originally created in Axure RP 9, please let me know.

it sounds like two of your three adaptive views are previewing correctly, but your custom desktop view is showing a rectangle near the top left of the screen when previewed. Is this correct?

It is correct. The rectangle is present only in the largest view of all the pages in which I have placed a “Header” master. However, I cannot find any hidden widget within this master.

The file was indeed converted from an Axure RP 8, but the Header master was not in there, as I created it already in version 9. Here are the two files:
Original file with Axure 8 (439.2 KB)
Current file with Axure 9 (847.6 KB)

Thank you so much in advance!

Hi Helionking!

Thanks so much for sending these along! I’ve taken a look through the files, and it looks like the rectangle is appearing on your largest view because the “Fondo contextual” rectangle that is unplaced in this view is displaying incorrectly when previewed in a browser. Instead of being invisible for this adaptive view, the rectangle is displayed. I will be filing a bug report with our teams regarding this unexpected behavior. While we investigate this issue, one workaround could be placing “Fondo contextual” in view, and then setting the rectangle’s visibility to “Hidden”.

Hopefully this helps some!