[Fixed] Get team project doesn't work

Hey there. My team and I just switched to Axure 9. We’ve exported our Axure 8 team project as an rp file, opened it and saved it with Axure 9 and then imported it as a team file again in Axure 9…

The team file is working for the team member who has created it but when other team members try to fetch it from the cloud (“get Team project”), the loading freezes at roughly 30%


I should mention we’re all using mac, the project isn’t insanely big (+/- 300Mb) and have tried several times. What else can we do? Any help would be appreciated.

Hi emaujean,

Hmm, to confirm, if you let the dialog box sit for a while does the retrieval of the project complete or do you get any errors? For a project of that size, it would realistically take several minutes to finish getting the team project. Although the current progress bar appears to be “stuck” when retrieving a large team project, it should still be pulling the data in the background.

If you’re seeing that the local copy retrieval results in an error instead, can you submit the error if it shows any submittable dialogs? Thank you!

Hey Alyssa,

No error, It just freezes for ever and we have to force quit Axure 9 to recover.

Any idea?

Same issue here. Hangs and can’t proceed past ~30% on an 80Mb project.

Seems to eventually timeout for me (after 30 mins or so) and returns to the Get Team Project dialogue but no error message…


Hmmm, interesting! Thank you both for the followups. If you haven’t already, would you both mind sending an email to support@axure.com and attaching your Axure RP error logs and post logs to the email? This will allow us to take a look at what’s going on in Axure RP when the team project retrieval fails. To find the logs on your Macs, please open the Finder and use the “Go > Go to Folder” menu to navigate to the following directory:

~/Library/Application Support/Axure/Axure-9-0/logs

Within that “logs” folder you should see both “error_log” and “post_log” files; please attach both types of files from the days that you’ve been getting these team project issues and we’ll take a look at what clues Axure RP is capturing in the error log details.

As a workaround for now, you can request that the user who created the team project check in everything on their end, save the file, and then send you a copy of the .rpteam file that they have. This should at least allow you to start working locally while we’re investigating the team project retrieval issue. Thank you! :slight_smile:

Hi guys!

We’ve received your error logs, and from testing one of the sent projects we were able to reproduce the issue; it looks like for team projects that contain hundreds of pages or masters the team project retrieval will retry the attempt and then fail. Our QA team has this filed and is investigating a fix; thank you again for sending all that info over to help diagnose the issue. In the meantime if you haven’t already, please try having the person who created the team project check in their changes, save the file, and then directly send you a copy of the .rpteam file. Hopefully that allows you to work locally for now.

We’ll post an update once there’s additional news, but you can also keep an eye out on the release history page for news on what fixes are being released in each build. Thank you!


I got my colleague to send the local copy of his team file, and opened it with my own licence of Axure 9 and it worked fine.


1 Like

My team and I just switched over to Axure 9 Team, from Pro. We’re all using Macs as well and experiencing the same problem.

On our Macs we are also seeing errors checking out / getting updates from individual pages. If we attempt to “Get all changes from team directory” or "Check out/in everything " under the team dropdown Axure will also freeze at the ~30% mark. However on my Windows PC everything works with no freezing.

This has especially been an issue due to the local files often getting corrupted when you force quit during a sync.

For now we will likely return to not using the Team related functions until a patch comes in, but fingers crossed for an update soon. (as i’m trying to transition my team from other prototyping software hah)


1 Like

Thank you for sharing those details, those are very helpful! Our team is actively tracking down and working on this issue that seems to cause problems with getting local copies of team projects on Macs, and we’ve also received reports of local copy corruption that seems to happen when users force quit Axure RP in the middle of a team project operation. From your description it sounds like this corruption can happen if you quit Axure RP when getting changes or checking in/out changes on Macs. I’ve relayed this information to our teams for discussion, and we’ll follow up if we need additional information to help track down the cause of this problem. Thank you again for those tips!

1 Like

Bump… We have the same problem on multiple team projects… Will be watching for an update. BTW - Also happens during large checkouts/get changes.


Thank you for that bit of info! We’re closer to finding a fix and will post an update here when there’s additional news or when the build with the fix is ready. In the meantime if you have Mac users who are unable to get local copies of the team project due to the hang, having the user who created the team project send them directly a copy of the .rpteam file should help for now. Additionally, since this issue seems to specifically occur when many packages have to be retrieved or sent, making smaller checkouts/commits (i.e. checking out/sending changes on individual pages instead of using check out all/get all/check in all) should help to avoid the hangs, which in turn should help to avoid the situation where you have to quit Axure RP in the middle of the process and risk a corrupted page.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi all!

We just released a new release candidate build (3651) that optimizes the creation of team projects and also should fix the freezes that you are seeing when attempting to get local copies/changes for team projects on Mac. This in turn should help to prevent the issue where quitting Axure RP in the middle of the above team project operations causes local copies to become corrupt. You can download the latest release candidate build here.

As a heads up, if any team members who have recently force quit Axure RP in the middle of a team project operation have any corrupt or partially corrupt local copies, then you may need to recreate the team project and grab a fresh local copy to avoid working with the files that are already in a bad state.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.