Repeater bug on Axure 9.0.0.3673 Team Edition

Hello,

This is the problem/bug I encountered:

  • create a new repeater widget and populated with some structured data
  • create a simple filtering option
  • wanted to filter by type, in my example im using two types: article and video.
  • assigned the interaction on the set of button controllers.
  • run the preview and filtered view give an empty view

I’ve done this multiple times using Axure 8 and never had any problem. Weird.

You can have a look at the sample working file here: https://www.dropbox.com/s/zc8zfiy59t062r8/test-repeater.rp?dl=0

Hey there - are you using a Mac? I downloaded your file and had a go and encountered the same issue. Then I noticed that my Mac was converting straight quotes to curly quotes on the fly. Curly quotes will break repeater filters.

I’m guessing this is something Apple have flipped on by default in a recent update. You can turn this off by going to System Preferences > Keyboard > Text and unticking ‘Use smart quotes and dashes’.

1 Like

Although come to think of it, this might be a bug introduced at the Axure end, if the field where you enter formulas is seen by the system as a regular text field and thus eligible for things like ‘smart quotes’. @Alyssa_Axure - this might be a bug? I had not seen it prior to the latest release.

Yeah - I am. But I never had this issue before, I was using axure 8 till this week. :frowning:

Yeah, I suspect it’s a new bug introduced either by Apple or Axure. The workaround above will fix it in the interim.

by the way - thank you for providing the workaround. much appreciated. :slight_smile:

Yep, we’ve got a ticket filed with QA regarding smart quotes interfering with repeater filters working properly, just to confirm here for y’all! :slight_smile: Hopefully toggling off that setting in system preferences works for people in the interim–thanks for posting that!

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.