Repeater filter with checkbox makes disapear all rows even if I unselect delete filters

Hi all,
I’m trying to add multiple filters to a repeater using a checkbox, when I select remove other filters it works but obviously for the last instruction so the filter shows me the last row where the filter matches the text - and does not show other rows where is the text that I want to filter - if I uncheck the option remove other filters, the repeater disappears. I’m using SELECTED OR UNSELECTED event and adding the different cases and targets


It seems like you are wanting to create “facet filters,” where you winnow a selection down by various “facets” (essentially, categories).

For example, for clothing, you might have a “Department” facet with checkboxes Men, Women, Kids, and a “Category” facet with checkboxes Pants, Shirts, Shorts, Shoes. Clicking Men, Pants, and Shoes would winnow your list to only mens pants and mens shoes.

If this is what you are looking for, there are a couple good methods of doing it.

Here is one method. The filters are more verbose, which makes it easier to have typos, but setting up the checkboxes is easy.

I like this method better because the filters are simpler, but setting up the checkboxes is more complicated. I’d just use the downloded file and copy the checkbox sets (along with the string they produce) for each set of checkboxes you need to create.

In both methods, you simply define your filters once, when the page loads. Clicking the checkboxes forces the repeater to re-evaluate the preset filters.

Important notes:

  • If you are setting up multiple filters (there will be one per facet) be sure to uncheck Remove Other Filters from them.
  • Make sure your Smart Quotes setting in Mac or Windows is off. Otherwise Axure’s filters won’t recognize the quotation marks as quotation marks. (You can use single or double quotes as long as you are consistent about it.) In the Mac system settings, it’s under Keyboard > Text. When viewed closely, your quotation marks will appear straight up-and-down, and not hooked.

Amazing! it works,
I had to copy and paste your statements - I tried by typing myself and wasn’t working seems Axure doesn’t like my keyboard.
As my intention is the final user can add more than one “issue” on their profile so Issue1 could be in the first column in one- in another profile could be in the 3rd column, I had to add in the same statement the “scan” for all the columns:


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.